Optimizing Z-Wave battery devices

Brand new to Hubitat. I'm in the process of moving 60+ Z-Wave devices from a HomeSeer environment.

For the life of me I can't figure out how to properly get battery-operated Z-Wave devices in place. I can add a motion sensor near the hub and it works fine, but when I move it to its permanent location it goes dead. In HomeSeer, I'd wake the device and perform a Z-Wave optimize on that one device a few times to get its mesh neighbors established.

But I can't figure out how to do this in Hubitat. Z-Wave Repair goes node to node, but if my motion sensor is node 60 then I need wake it up when it gets close to 60? I have to be missing something because I can't find this topic on the message boards.

I'd appreciate any help. Thanks!


Are all of your devices battery operated? Or are you trying to add the battery operated devices first? I'm simply speculating, but I'd suggest adding some repeaters in to your network such as zwave switches if you have any. Perhaps most of your problem lies in your network itself? What type of devices are falling off? Sometimes they say inactive, but still respond. Maybe, if you could, explain your setup with a bit more detail. That might help with troubleshooting. I've only had problems with some zigbee motion sensors. So it seems odd unless there's a lot of distance in your setup or brick walls, or something.

Thank you for your response. No, most of my devices are wired switches. I have all of these added to Hubitat and so far those are working really well. The network is rock-solid.

Now I'm focusing on the battery-powered devices (5 or so of them). I think I made the mistake of adding these devices near the permanent location of the Hubitat hub. So they communicate properly with the hub when located < 10 feet away, but when I move the device to a permanent place (in one case 60 feet away) they don't communicate at all.

So my guess is that one of two things has to happen:

  1. Move the battery-powered device to its permanent location, and remove and reinclude it into the Z-Wave network from there by dragging the Hubitat hub near to the device, or:

  2. Somehow instruct Hubitat to send a code to the battery-powered device to perform a Z-Wave repair. In this case, I'd wake up the device and perform the repair, at least that was the procedure in HomeSeer.

I'd much prefer option 2, hence my question. This is not an issue of walls or interference, since the locations of these devices are among many wired devices that communicate just fine.


I don't see why you would want to move the hub near the device, as that would result in the device simply pairing directly with the hub again?

Why not try pairing the device in its permanent location, with the hub in its permanent location? If you're Z-wave mesh is strong, they should pair through one of the repeaters (as long as they do not require secure-pairing, like some door locks do.)

These are ancient devices, namely the ZIR000 and the HSM100. My understanding is that the Z-Wave protocol of that era does not allow pairing through repeaters. As it is, pairing these things are a challenge even in a perfect scenario. :slight_smile:

I think I'm answering my own question in that I need to exclude/reinclude these devices at their permanent home.

One last question: how does Z-Wave repair work with battery devices, even with the newer Z-Wave protocol? Does the repair queue until the device wakes up?

Thanks for all your help!

This is probably a question best answered by the Hubitat Engineering Team. @mike.maxwell or @chuck.schwer might be able to answer your question regarding Z-Wave Repair.

1 Like

I'm gonna say that @ogiewon is right. Or I'd respond with "I dunno. I'd just start the repair and walk around the house a while. If you can get the one that your'e dancing in front of to respond, then do it again with another? " :slight_smile:

1 Like

If you exclude and then reinclude, I feel like you should do a repair in between and maybe reboot your hub in case there's chatter that you can eliminate to make the process easier. I know some people may argue that, but I've had better luck with including things after a reboot. Especially if you've excluded the device. Repair and then reboot.

1 Like

Remember ZWave repair takes about 1 mins per device.. 30 devices, it's probably most of 30 mins to be done.

So don't get overeager on the reboot is what I'm trying to say. Don't click ZWave repair and then Reboot a few seconds later :slight_smile:

Well my "solution" was to upgrade my motion sensors. I got Zooz ZSE40's and they work really well. A huge step forward from those old devices.

My question still stands though for @mike.maxwell or @chuck.schwer: how does Hubitat handle Z-wave repair with battery-powered devices?

Thanks all for your input! :+1:


I am curious about this as well...like, does the hub flag devices that don't respond immediately and then when a report from a device comes in, cross reference and do the repair process for that device? Or how else can we know to wake up battery devices when a repair is in progress?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.