OpenWeatherMap-Alerts-Weather-Driver

Just for clarification. I just signed up for the 3.0 API and gave it a credit card. However I continued using the API keys I had previously generated. I switched the switch in the device to 3.0 and everything appears to be working.

So I don't need to generate new API keys now that I have the 3.0 "subscription"?

Their web site is not great. It shows that the only thing I have under the Services tab is the free service. Yet when I click on Billing Plans it shows that I have the Open Call API 3.0 - which I guess they don't deem to be a service and so don't list it on the Services tab?

2 Likes

I created a new key. But, I am not seeing anything that makes the new key "special" to indicate it is a 3.0 and changed the app to the new key. I gave both keys a friendly name with the API version numbers just in case there actually is a difference.

1 Like

Curious if anyone has a suggestion. I upgraded to the latest driver and have been using the 3 day forecast attribute on my dashboard. The icons have stopped processing and I am not sure if I am missing something. Thanks, Dan

Did you sign up for a 3.0 api key or are you using the older version? I would try posting your config and any logs as that might help?

I see that as well. I signed up for 3.0 about a week ago - only noticed today that the icons aren't there. I'm certain they were last night. hmm.

The icons have nothing to do with the OWM API. The are pulled from the site you specify in the drivers settings. Make sure that site is not being blocked by a DNS filter (Pi-Hole), virus protection, etc...

Looks like the tinyurl site may be having issues? When I try to access a PNG file, I get an error about Cloudflare not being able to resolve the name. My forecast tiles were broken for most of the day. Mid-day, I noticed that one tablet was showing the icons and images correctly, but now it is not. This appears to be Cloudflare or TinyURL having issues.

It does look like tinyurl/cloudflare issue. The icons have been sporadic lately. Not an issue with the driver.

fwiw - icons are back for me tonite.

They returned shortly after my previous post about this being a DNS issue. Murphy must have been watching, or listening.

I think I found a bug. The override lat and long are used even after the option has been turned off.

  1. Turn on: Override Hub's location coordinates
  2. Enter lat and long
  3. Save
  4. Turn OFF: Override Hub's location coordinates
  5. Save
  6. Poll. Driver still uses coordinates from step #2

Since the lat and long are required, they can't be blanked out before the Override option is turned off.

[UPDATED V0.7.0 05/13/2024]

Corrected moon phase

If using HPM do an Update or a Repair. Otherwise open the driver code and re-import the code. Thanks.

3 Likes