[OLD] MQTT app beta1 and pre beta2 - please use beta3 thread

@mike.maxwell any chance for creating Hubitat Virtual Pressure Sensor or is it completely out of the scope?

I am very new to MQTT. I have a broker setup and can connect to it using MQTT Explorer, but I get the following repeating message. I tried completely removing the driver and app, restarted the Hubitata, and reinstalled, but the same message pops:

2020-06-01 04:21:37.394 pm infoMQTT> MQTT connect failed attempt:[null], try again in 10 secs

dev:652020-06-01 04:21:36.362 pm infoMQTT> Connecting as Hubitat_temporary to MQTT broker null

dev:652020-06-01 04:21:36.357 pm infoMQTT> MQTT> client null temporary

Maybe a view of my broker config will help. If not, post yours so we can see what you're doing.

I could post it, but it looks nearly identical...except for the Hub Name. I have the tcp and the port the same.

OK, which broker are you running and on which operating system? What network components lie between your HE and the broker system? Using any firewall?

Have you rebooted HE after installing the MQTT app?

Mosquitto runnning on a Synology NAS. The HE is on a different subnet than the broker, but it's on the same subnet as the MQTT Alarm Panel that can connect. The gateway has full, bidirectional allow rules between the two internal subnet, and the traffic logs do not show any indications that the traffic is dropped.

Can you run wireshark on any system in the path between the HE and NAS? I'm not familiar with the NAS so I don't know if wireshark runs on it but that would be a great place for it.

Hi both, The MQTT app is not communicating with it's child MQTT driver, here you see the null/temporary details.

Can you delete any and all MQTT Client type devices that may have been created and then just restart the app which will re-create the child again. You don't need to delete the actual driver code.

I think maybe the device wasn't created as a child the first time. You can see this within the device itself...


Deleting the child device and restarting the app worked.

Sorry Frank, this is my fault - apparently an app isn't 'installed' until you first hit done. Strange but true. I thought it was installed at the time you 'added' it.

I create the child device before you hit done and so it isn't actually a child of my app at that stage . I will fix that.

This is a beta3 issue and does not impact beta 1 or 2 users. I just noticed it's in an old thread.


In the meantime anyone with this issue delete the MQTT Client device and re-run the app.

How do you get access to the beta3 thread?

Have edited the original post link which wasn’t working :thinking:

The instructions are for beta 2 .. just updating them now. Read the first few posts in that new thread to get going for the time being...

@troywehrle did you ever get the Heater Thermo configured? I am using AqualinkD as well, and wasn't sure how to set this one up. This and the lights are the only things I have yet to configure. Any assistance is much appreciated.

The virtual thermostat inbuilt to HE has too much intelligence inbuilt and will interact with the remote MQTT thermostat in undesireable ways. Instead you should use the 'remote thermostat' driver that I have created and will be available in beta 3e . It has no intelligence at all so accurately represents and controls a remote thermostat. It maybe that you would want to pre test this ?

Also this is an OLD thread (I know you were replying to a post within) but the current thread is here

I ended up not using the thermostat devices. Just using simple temp sensor devices.

Thats pretty slick, Mind if I DM you directly to get it off of this old Thread? I had just a few questions.

That's fine.

I am new to the Hubitat world (but not to home automation, ZigBee, Z-Wave and so on).
I am trying to install MQTT but I am having problems.
I have imported the app code and the two drivers code.
If I do then App-->Install New User App, everything hangs and nothing is installed.
I have deleted the device and reboot the Hub by without success.
Any hints?


Which version of the MQTT app are you installing? Beta 3d is the current published version, this thread is an old one.

What do you mean by everything hangs? The app does not install and HE hangs?

Please use this thread.. and check you are using beta3d.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.