Oh Oh - Hub disappeared

Well....this is an odd one.
Ive been running a C5...for years. Has always worked great.
This morning i decided to connect a c7 as i wanted to set one up here in my home, configure it then transfer to a friends house.
I added the C7 and both of them were operational.

I'm certain both were operational as i had to exclude a HSM 200 multi sensor from the C5 to connect it to the C7.

I tried adding a Jasco 40 amp switch to the C7 but after 3 or 4 tries i wasn't getting anywhere. So i decided to try and C5 and see if it would join there...but the c5 disappeared.

I keep a favorite for accessing my c5 on my browser. Didn't work..just got the skinny wheel ...then i tried find my habitat...but the only hub showing was the C7

I disconnected the c7 ( power and cat5)
Rebooted the c5..for a full 2 or 3 minutes off
Still no love.

I even rebooted my computer and made sure my wifi was off..to force everything through the same switch back to the router. No love.

The green lights is illuminated on the C5.

to make sure this wasn't a computer issue..i re connected my c7 and i can connect to it no problem.

Luckily i bought the hub protect..but id really like to try and recover the c5 and get it operational. any thoughts?


Get a network scanning app and see if you can see the C5 getting an IP address. Is the C5 assigned a static address or using DHCP?
I like NetAnalyzer by Jiri Techet

No assigned IP.
Will look for a network scanner. For iOS

Try this:

1 Like

No love. I just get a spinning wheel.
But when I plug the new c7 back in it finds it instantly.

I logged in to my router / devices.
when the C7 is plugged in - i can see its IP address
When the C5 is plugged in - i CANNOT see its IP address.

When i power it on - starts with a blue light - then turns green a min later.

Doesnt look like its connecting to the LAN.


Can you get the IP that your hub was using in your shortcut you had in your browser? Not sure if the C5 has the diagnostic app...but if it does you should be able to get to it at:

http://[hub IP address]:8081

Does that work?

All Hubitat Hubs, from the C-3 through the C-7, have the diagnostics tool if they are running a relatively recent version of the Hubitat platform software (i.e. not the original 1.x platform.)

The C-5 and C-7 are identical, except for the Z-Wave Radio and associated software. Everything else is the same (i.e. Zigbee radio, CPU, RAM, eMMC, Ethernet, etc...)

Please try resetting the C-5 Hub's Network settings by using the small Network Reset button on the bottom side of the hub. Hold the button in for at least 7 seconds and the hub should reboot itself and attempt to obtain an IP address from the DHCP server.

1 Like

Well. After several more hard reboots the hub came back online.
I didn’t have to to the network reset.
Be nice to know what happened but as long as it’s working:)

Had an error that said the zigbee network was off….though in settings it was showing enabled

Going to install the latest firmware then give it another reboot and see what it says.
Hopefully it’s all working!
Will report back shortly.

New firmware.
Re booted.
All working.

Gremlins !

Either way. I’m shutting it down when I play with the c7. I know you shouldn’t have to but not worth going through that again.

1 Like

Are you restoring a backup from your C5? If yes a static IP assigned via hub’s network settings might carry over and thus cause an IP conflict within your network. Believe I did this once with my hubs a while back.


The damn gremlins are at it again...this tine i cant find the new C7.
So yesterday the opposite occurred. I added a new C7. My C5 was working .
On the find my habitat page - i could see them both on my network.....as noted form the posts above - the 5 dropped off and nothing i did brought it back. But after several hard boots.....it just came back on its own
After that - both were available to me.
This morning - after playing with some devices on the C7 - i decided to move the hub closer to where im playing with the new devices added...i unplugged it and moved it to a ethernet connection - that i tested and was connected to my switch,......couldnt find it. Found only the C5

Moved it to another network connect....couldnt find it. Only the C5.

Moved it back to my office - where it worked just 20 mins earlier...still only the c5.

I powered down the c5, rebooted my router.....nada.

I used all of the different methods to find it.
http://[hub IP address]:8081....with my ip address
Advanced discovery with the mac address and advanced discovery with the hubs IP address.

Going to try that network reset as suggested above.

I honestly don't think i have any thing wring with my network. i can log on to each of those network ports with my laptop and i get straight to the internet.



Tried the network reset....with the hub powered and unpowered...Nada.

I even had the C7 plugged into the same switch as the C5...literally the port directly next to it....seen the C5 but not the c7.

Going to plug it while i do something else for a while. Not sure it will help but nothing else has helped yet.

Only thing i haven't noted. Twice when i tried the mac address..it found something but still won't log on.
I can see the following message.
Found by mac address
But when i press on it - it redirects me to portal.hubitat.com...then hangs.


Aaaaand....it back.
Im going to move it again....hope it doesnt drop off yet again!

Sounds like it is having a problem either negotiating the link or getting an IP via DHCP.

In the network settings, under Ethernet Speed, what it is set to try the opposite setting. That is when you can get on it to change it.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.