[OBSOLETE] Zooz Double Plug

Thanks...I think I figured out what was going on. A new device does not always show up on applications like scenes or Alexa or whatever right away. I've had to go in and out and in and out of the app and it finally shows up. So it was not the driver at all. Sorry for the false alarm. The driver works great!

I'll ask about the delay in accessing a new device in another thread.

just used it works awesome thanks

Hi @krlaframboise
Am I correct that this is no longer needed? I am using it but think that an issue is due to me not using the stock Hubitat version. Can you or someone confirm this is not needed to use the Zooz SEN25?

It's needed to change the settings, but basic functionality probably works with the built-in handler.

What's the issue?

I moved to the built in handler for now. I now think I have a Z Wave issue. 3 Repeaters in the same room (2x Zooz Zen25, 1 Lutron outlet).

Thank you for the reply, I will will troubleshoot this issue.

Hubitat ended up adding support for the USB reporting to their built-in handler and I think it also supports all the settings in the latest firmware so you're correct, there's no reason to use this handler. (I forgot I wrote a custom Hubitat handler and responded from my phone thinking this was the ST forum)

That being said, unless the handler was increasing the number of reports sent to or from the device, which this one doesn't, there's no way the handler could be causing your z-wave issues.

The more reports it sends, the more z-wave issues it will cause, so set the frequency reporting to the highest setting for all the measurements you're not doing anything with. You should do this for all your metering z-wave devices...

1 Like

@krlaframboise - I'm having some issues w/the built-in driver so I was going to try yours. I changed the driver for the main plug instance to your Zooz Double Plug Advanced, but I can't change the driver for the two existing child devices, the option to select driver is greyed out, as is the option to remove.

Looks like I have to exclude it and try again -is that correct?

From device page for one of the child devices.

Correct, Hubitat doesn't allow you to delete or change the type of child devices so you'll have to remove the device and join it again.

1 Like

Thanks, I'm only using it as a repeater right now, so I'll wait until the C7 FW update and then go back and fix it.

Really glad you're here on HE, I was a regular user of your ST DTHs/apps, and always appreciated your extremely helpful posts.

@krlaframboise I'm seeing an odd error in my logs related to the Zooz plug. I've included the plug as a secure device on a C7 hub.

Full log error:

2020-09-28 14:27:05.747 errorgroovy.lang.MissingMethodException: No signature of method: zoozDoublePlug.parse() is applicable for argument types: (hubitat.zwave.commands.supervisionv1.SupervisionGet, java.lang.Short) values: [SupervisionGet(statusUpdates:false, reserved:0, sessionID:11, commandLength:10, commandClassIdentifier:50, commandIdentifier:2, commandByte:[33, 50, 0, 0, 0, 0, 0, 0]), ...] Possible solutions: parse(java.lang.String), wait(), run(), reset(), run(), grep() (parse)

I was seeing same error if I remember correctly and they didn't work reliably. I re-paired them unsecurely and that error went away and they seem to be reliable now. If someone knows the cause, I would consider re-pairing securely.

EDIT: This is using the built-in driver.

The built-in handler supports all the features and I figured they would have fixed the bugs by now that were causing users to use mine so it wasn't worth spending time adding the S2 related code and I was planning on marking mine obsolete...

Interesting thanks for the quick updates. I'll roll to the internal driver, Which built in Hubitat driver works best here?

I'm using Zooz Double Plug

Did you pair it securely and did you have the error that @tedrpi showed?

Didn't see a need for it to be secure so I have no security at all on it.

Definitely seeing the errors using the built in Hubitat driver. Guess I'll exclude and re-pair insecurely, disappointing.

@agnes.zooz any suggestions on a working driver for S2 paired double plug?

There should be a fix for it coming in the next HE platform release.


Still getting errors on the built in driver for these. I'm on a C7 hub, platform version, and device firmware version 2.0. I've tried using @krlaframboise's driver, but it is not being selected when including the device. I've tried excluding and including multiple times, doing a factory reset, rebooting the hub, and deleting and adding the driver back to my custom drivers. Am I missing something?

Edit: I finally managed to do an insecure inclusion using the built in driver. It's no longer spamming my log with errors. I still don't understand why it won't select the custom driver.

@Derakkon - as Agnes from Zoom says below, an update for the double plug is coming in Hubitat next release 2.2.4. I've set mine aside until then, just not worth fighting with it at the moment. :slight_smile: