OAuth Not Enabled

I'm trying to create a new rule using a cloud endpoint. (2.2.5) When selected the toggle in the trigger drop down I get this error: " java.lang.RuntimeException: OAuth is not enabled for this App on line 1380 (selectTriggers)"

I can't figure out how to enable OAuth. Any Help?

Tagging @bravenel. I can replicate this issue--just try to add a cloud endpoint trigger to a new rule, and it happens. Since you're creating a new rule and you're on 2.2.5, this should be Rule 4.1, which is new, and I'm guessing maybe they forgot to set something to enable OAuth for this new version of the child app. But we'll see. :slight_smile:

Same issue with LocalEndPoint.

I've found some other posts about OAuth, and they say it is an option when installing. I don't remember seeing that with Rule Machine.

Anyone know, if I uninstall Rule Machine and install again to test it, do I lose all my rules and have to set them up by scratch again?

Rule Machine can export and import rules now. But I would wait to see what @bravenel says about this before taking action.

Thanks. The Export/Import says "(Beta)" so I wasn't sure if it was trust worthy.
I'll wait before moving forward.

1 Like

It's a relatively new feature, and I haven't followed it closely, but I don't remember folks having significant problems export/import on their own hub. But yes, waiting is the smart money right now. :slight_smile:

I just tried exporting a rule from one of my hubs (download to my pc) and then importing it to a different hub (from my pc).
It worked well in that it imported the rule structure but you do have to put in the devices (the same options as you get on cloning a rule within a hub) as the device doesn't exist on the second hub, these are empty.
It does work though.

As for deleting rule machine. I would assume that if you deleted rule machine parent app then all child apps (rules) underneath it will also be deleted.
As for oauth, I don't remember it asking for oauth when the app is installed.

I suspect we missed enabling oauth for Rule-4.1. Looking into it.

That's for user apps. The built-in apps should be magically configured by staff as part of what's baked into the hub firmware, so we don't need to (and can't) do this for those. :slight_smile:

1 Like

Thank you for the clarification. Still learning! :slight_smile:

I just updated to 2.2.5.122 and I’m still getting the oauth error even though it’s in the fixed list. @bravenel @bertabcd1234

its for sure in there, have you tried recreating the rule since doing the update?

I tested and it is fixed for me as long as you make a new rule. Adding it to an existing rule did not work. (EDIT: So ... what Mike said. :slight_smile: )

3 Likes

I installed 2.2.5.122, then created a new rule, and I still go the same error.

On a hunch, I went to Settings -> Reboot Hub and I rebooted my Hub (after the upgrade.)

After the Hub reboot, the Local End Point worked on a new rule.

1 Like

@ronbissell reboot sorted it. I thought the hub rebooted after an update, guess not. Many thanks!

@mike.maxwell @bertabcd1234