NPE While Trying to use the FW update tool

Every time I click the "Update Z-Wave Firmware" button in the Device Firmware Updater app I get the following:

Unexpected Error
An unexpected error has occurred trying to load the app. Check Logs for more information.
Error: Cannot invoke method getDataValue() on null object

In the logs I find the following:

2020-12-17 09:03:13.068 am [error](http://.../installedapp/configure/51)java.lang.NullPointerException: Cannot invoke method getDataValue() on null object on line 77 (firmwareSelectorZW)

I've tried rebooting and still encounter the same. Only change to the network is that I've moved from testing Hubitat with a Inovelli red switch and 3 Inovelli RGB bulbs to using it as my primary hub (previously Smartthings) with about 30 Inovelli switchs and dimmers and 11 RGB bulbs.


Which device are you trying to update, and did you define the url where the firmware update is located?

Should have included in my initial post this is a C-7 hub.

I'd like to update some of the Inovelli RGB bulbs. I have the 2.30 FW uploaded in the Firmware File Manager:

I experience the issue described above when I click the "Update Z-Wave Firmware" button so I'm never given the opportunity to select a device or firmware to apply to the device.

Tagging @bcopeland as I may be mistaken, but I don't think you're going to be able to update those bulbs with the C7. In fact, the compatible devices list has been updated to now recommend that Inovelli bulbs only be used on a C5 or earlier HE hub. The reason is the Z-Wave 700 chip forces devices that don't support S2 security (those bulbs) to join as S0 and that's a lot of overhead that makes devices slow and can make them perform unreliably.

I recently updated an Inovelli LZW36 and after an hour the update was only at 5%. Then I remembered Bryan telling me that I need to join it unsecured (which is possible with that device since it supports S2 security). After doing that, the entire update finished in an hour. So if you have devices that support S2, it shouldn't be a problem.

Note that if you do like those bulbs, you can join them without security using a secondary controller. There are a few posts in the community detailing how people have done that with a Z-Wave USB stick and Z-Wave PC Controller (requires Windows), though I suspect any secondary controller would work if it's not a certified 700-series hub (this is just the easiest option except for the Windows thing). You won't get the S0 problems on the C-7 then. People seem to have particularly bad luck with some devices, like the Zooz 4-in-1 (ZSE40), even though the only theoretical problem with S0 should be the extra chattiness.

Unless there's more to the story with these particular devices that I don't know about. :smiley:

1 Like

As you note, the Device FW Updater error your getting should not be related to a specific device you're trying to update, since you haven't even gotten to the point where you can select the device you want to update.

Just a note that I've gotten similar errors w/the app when selecing Update Z-Wave Firmware, and seem to have resolved them by uninstalling and re-installing the app before each FW update attempt. Probably overkill, but I don't run into any odd errors anymore when clicking the "Update Z-Wave Firmware" button when I have a fresh install.


Correct, never had the opportunity to select. But the uninstall/reinstalled seems to have corrected things.

@bertabcd1234, appreciate the heads up on the LZW42 bulb compatibility I wasn't aware of that. I'm still relatively new to all this.

Appreciate the help!

1 Like

Yep. Bryan Copeland indicated to me, when I was bit by this bug almost a month ago, that it’s a missing data initialization issue that occurs when the last previously-updated device is no longer on the network, Happened to me after I updated my ZEN16 MultiRelay (which, like other Zooz devices, had to be excluded, factory reset, then included (at a different node number), leaving no device at the previous node), then tried to update a bunch of Aeotec Recessed Door Sensor 7 devices.

He indicated that he was tracking it down, to be fixed in a future release, but that the work-around was to remove and re-install the app. I believe that Bryan has been very busy lately. :slightly_smiling_face:

A phrase that has been true for quite a while now... [eek!] Hard to find a harder working person lately.

Thanks, was getting this same error. Removing the app and adding it back again fixed it for some reason.

1 Like

This is reproducible. If you exclude/delete the last device the firmware update tool was. using, it will leave a "deviceToUpdate" configuration setting which basically breaks the tool. The tool tries to automatically index to that device you were last attempting to upgrade, and since it's not there anymore, the tool breaks.

1 Like