Notifications not updating in app - Fixed!

The notifications app isn't required for notifications (as in send message to device) any RM rule can do it.

This rule sends a simple message to my phone

I don't even have RM installed because I do everything via webcore. I'll install it and set up a simple rule for notifications.

1 Like

webCoRE can send push messages also

I think the problem is webcore isn't doing that for him at the moment but if he goes to his pushover device and sends a test message it does go. So something in the way webcore is looking at the device is wrong.

webcore absolutely is pushing the messages to my phone. it's just when I click on the notification to read it, it opens the HE notifications screen and just spins.

Is pushover receiving them?

Here's the steps and screenshots:

Create a piston:

Trigger the piston and wait:

I am receiving two notifications because I still have my phone as well as pushover version of my phone connected to this to show that they behave the same.

Click the hubitat notification and it goes here:

Then click the notifications (because remember, I am still trying to go see the rest of the message from the banner notification):

It just spins. THIS is the problem. Not the sending/receiving. The storing of messages seems to be a problem.


Ok, so you can open pushover and see the stored messages not in the HE app. I finally got it now... I was a bit confused earlier. Honestly I would just leave pushover in place if that's the case. If you must have the HE notification, maybe @gopher.ny knows a trick. It seems like the cache on your phone for that app is somehow corrupt. (I'm sure it may be more complicated than that). As stated earlier you removed the HE app and reinstalled. (did you shutdown between uninstall and install?)

Mine work from webCoRE, but I have run into a situation where a get a Token Error on the Notifications screen, followed by a blank screen, if I switch hubs. (Going to have to play a little to document how to break and then fix…)

I did remove HE and reinstalled (I definitely had to re-add the phone as a new device when I reinstalled). I did not restart in between.

My phone has not changed since I originally set up HE. And to my knowledge I've never seen a notification on this notification screen.

This is exactly what's happening. It doesn't actually throw the error on android (it just spins), but it throws invalid token error on ios (as of yesterday). I have two hubs as well and I thought at one time that could be causing the conflict so I changed my logins for both to be the same and that didn't help.

The notifications screen is before hub login so how does it even know which hub to retrieve notifications from? This is hypothetically thinking if I had messages coming from two different hubs (I don't, all my messaging is coming from/to a singular hub). But it begs the question, how does the notification screen know? And is my notifications screen confused because it doesn't know which hub to retrieve them from?

Notification screen uses the last selected hub…

Well then that would always be my primary, which contains webcore, and where I would expect the messages to be going. My primary is almost always the last hub I would've been logged into.

Looking at the other tabs across the bottom, this is definitely the primary hub (has all my devices). Just nothing in notifications.

This doesn't seem truly solved. I read through this topic and thought "there has to be another way" and "what could possibly be the reason?"

Instead of uninstalling/reinstalling the app. I went to settings (in the mobile app) > about > HUB ID: ----

If this number doesn't match the Device Network ID* in the HE device / driver for your phone, then you need to change it. I just tested and it worked!

But now I get multiple notifications from the same rule, no repeats in rule, not sure what's up with that...

Look at the device and see what its in use by, You could have created multiple notifications

Hi - I'm having this issue

I missed a notification that worked the first time - so I am trying to find out what happened.

When I open the device log -the one highighted from 10/26 worked as expected, the one from yesterday 10/29 I never received.

so I open the app on my phone to see what's up and go to "notifications" and I get the message that says Error - invalid token.

I removed and reinstalled the app, thinking maybe a recent IOS update might have buggered it... but after reinstall I still get that same error.

Any suggestions? I only have this one basic rule using notifications.

You have a second notification device that looks like the working one but uses an old token. Everytime you sign into the app it asks if you want to create a new device. Probably where it happened. Check your device list carefully and if found remove the invalid one.

I only had my phone once under devices, but just to level set I just removed it from the basic rule, removed it from devices… uninstalled the iOS app, reinstalled the phone app, created a new device when it asked - open notifications from tools and still get Error- invalid token