nodsjs-poolController with Hubitat

I have been reading that there is support for nPC with Hubitat, and I am considering purchasing a Hubitat to try it out. I already have nPC up and running wonderfully via a local web interface dashboard. Before I purchased a hub I thought I would check in on this project first.

Some older threads mention @brad2 and some awesome work he did a few years ago on this topic. I was going to attempt to follow along.

Is this still possible, and are there any guides/writeups that I should read up on? Thanks!!!

This is working fine for me with Habitat and njPoolController. I have been running the code as published in Habitat Package Manager all year this year and it's working great.

Awesome, thank you for the fast reply.

I see that CS7's are readily available for cheap. Since I currently have only network devices (nPC on a RPI, Nest products, and a future Konnected alarm) any concerns with going with the older Hubitat to get started?

Hi @brad2 . I have used your hubitat integration for a couple years without issue. I have also setup on a friends system without issue. However, mine stopped working recently so I completely removed the app and reinstalled, but neither the autodiscovery nor manual configuration methods are working. I have also tried to add directly from the rPi that njsPC is installed on without luck. DashPanel discovers njsPC without issue. Any thoughts on how to resolve?

@farside847 the c7 works great and shouldn't be an issue with the dvices you mentioned. Keep in mind that it does not have wifi on board so will need to be hardwired to your network.

I can confirm this. I am running it on a C5.

Well, I haven't tried that and now I am afraid to break it in the middle of pool season. I could test it on my development hub though!

Anything in the logs if you put that App into debug mode to give us a hint?

Below are the logs when attempting from my c8 hub.

However, I then attempted from my c7 hub and it worked fine. Must be something interferring on my c8 hub but unable to tell from the logs.

1 Like

Perhaps something has changed with the way LAN devices work on the C8. I do not own one to test with that newer platform.