Nodon Soft Remote not connecting

I've been trying since yesterday to get my new Nodon Soft Remote to work (model CRC-3-6). Most of the time when I try to pair the remote with the Hubitat in "Gateway" mode, nothing happens - after the Nodon flashes pink to confirm setup has started, it sits quiet for 15 seconds then flashes red indicating failure. A few times the Hubitat started to recognize the device and showed "Found Z-Wave ## / Initializing", but it just hangs there indefinitely.

Just once I got it to fully recognize and add a Generic Z-Wave Button Device. However, after setting that up nothing happened when I pressed any of the remote buttons. I had debug logging turned on and watched that while pressing the buttons, and it was completely silent. While troubleshooting this I tried removing the device in exclusion mode, but that wouldn't work either; I had to "Force Remove" it on the Hubitat and to a factory reset on the Nodon. Now I'm back to being unable to add the device again.

I also tried installing Nodon's drive code from Github (, but that fails with unknown class errors:

unable to resolve class physicalgraph.zwave.commands.wakeupv1.WakeUpNotification @ line 122, column 16. unable to resolve class physicalgraph.zwave.commands.centralscenev1.CentralSceneNotification @ line 156, column 16. unable to resolve class physicalgraph.zwave.commands.batteryv1.BatteryReport @ line 165, column 16. unable to resolve class physicalgraph.zwave.Command @ line 180, column 16.

I'm at a loss at this point.

I also got a Nodon Octan Remote (CRC-3-1) which I just now tried to set up. It shows nearly the same symptoms: Hubitat is looking for devices, I set the Nodon for gateway mode, it flashes pink to confirm, then nothing else happens. In the Octan case, it doesn't even flash red - there is simply no further activity on either the remote nor the Hubitat.

In Gateway mode it appears that this device should operate as a central scene button device, which HE supports. When you added the device to HE, what did it get identified as when paired? Just Device? Did you then switch the driver to Generic Z-wave Button and hit CONFIGURE in the device edit page? That part is crucial when you swap assigned drivers, other wise the device won't work correctly. It should then report back which button is pressed when you press one. If the generic doesn't work though, you may need a custom driver. But start with the generic and make sure to hit configure. Also, don't "create" a generic z-wave button device, just modify the one that is paired to HE.

I don’t remember what driver was automatically selected; I think I had to manually change it to Generic Z-Wave Button Controller.

I tried it again just now and it did detect a Generic Z-Wave Button Controller automatically, and it is recognizing all button presses. I didn’t do anything different for the setup this time; I have no idea why it suddenly decided to work.

After updating the Hubitat firmware to version (hotfix for a different issue,) I tried connecting my Nodon Octan Remote again. That one is still not working; Hubitat is still ”Looking for devices” and I got no response on the remote.

I don't think if that one is going to work. Can't find definitively if it does central scene control. Try a zwave exclude first and then see if you can pair it with the hub.

The Octan should be functionally equivalent to the Soft remote; they both have the same buttons and technical specs, only the casing is different.

Nothing seemed to happen when I did the Z-Wave exclude. I then did another factory reset on the Octan and tried discovering it again, but there was still no response from the Hubitat. Tried it one more with the live logs turned on; nothing at all showed up in the logs, but this last time the Octan flashed red after several seconds.

I tried connecting the Octan remote again last night. This time it decided to work flawlessly, just like the Soft remote. Again, I didn’t do anything different; it just seems very temperamental.