Nodered and Ecolink Tilt Sensor - Not seeing any events

This may be an "edge" case, but is anyone using the Ecolink Tilt Sensor (https://www.amazon.com/gp/product/B01MRZB0NT/) and Nodered?

For some reason, I don't see any events from this device. I can get current state by using an inject node but there is no event generated when the state changes (open/close). I have tried with the event node as well as with the device node (with the send event box checked) and nothing shows up. I am trying to use this in place of my somewhat unreliable GoControl garage door open contact sensor but I need the event to trigger other automations.

I have a notification set up in HE on open/close for this device and that is working fine. Any idea what I am missing?

Go to the node-red MakerAPI instance. Remove the tilt sensor. Save and exit.

Go back and add it again. My guess is it will start working as expected.

Edit: I experienced something very similar

1 Like

I have 2x of that device, and use them in node-red with no issues.

I would try @aaiyar suggestion.

2 Likes

Yeah - I saw that one. You were adding an new attribute to an existing device, right? In my case, this hasn't worked from the start. I'm fairly certain about this as I log the events to a database and the reason I started looking at debug was because I wasn't seeing any entries in the database.

I then went in and created two small flows (one with the inject node+device node and one with the event node) to check if the event got published, but I saw a bunch of other events, just nothing for this device.

I will try the remove/re-add and see if that fixes it. :crossed_fingers:t4:

1 Like

Quick q: Do you have the Suppress Duplicate events option turned on?

Right again - as always!! A virtual bow to your expertise :grinning:

3 Likes

yes

3 Likes

Download the Hubitat app