Node-RED nodes for hubitat

Oh, I have complained about the one issue, but

GREAT WORK! I don't know if it really is faster, but it feels that way!
Craig

2 Likes

Arg ... I don't know why I totally reversed logic...
I will fix it, Thanks :+1:

Hey, if that is the worst thing I have to report, you are doing great.

I just accidentally made an infinite loop on my node-red 1.1.beta install with the new debug node status feature and a status node... Locked up my VM... Once again showing that most issues are user generated, not developer generated. lol

1 Like

Maybe not related (or maybe), but I've just found a big issue, that duplicate ws connection if you redeploy. You may need to restart node-red

ok, here it goes. If the virtual presence device is present, and you hit arrived, the event is broadcast, but does not show up in events. It does show in logs. On HE that is.

I think it might be a HE bug.

1 Like

Yes, I see that as well.

I don't think it is a bug, though. I believe the ws events happen before the de-dupe in the hub database (for increased speed). I seem to remember Hubitat explaining that before.

So if using ws, the end user needs to de-dupe events manually (if needed).

Yeah, Virtual contacts do the same thing... Not sure I agree with the model, but I will go to Node red and rework my presence code.

1 Like

Just need an RBE node (set to msg.payload.value) after device nodes, when dedupe is needed, I guess.

1 Like

I released a new version 1.1.1

  • fix delay between reconnect
  • fix node icon status
  • fix close websocket on redeploy

edit: now available on node-red library

1 Like

fixed, nothing to see here...

1 Like

Just upgraded to 1.1.1. I'll poke around at it today.

Can anyone share a Hue(magic) dashboard flow with a slider/color picker?

I've got one that works, except it doesnt update the dash slider if updated from the Hue app.

::: grrrrr ::::

alexa-remote2 is broke again... sick of this.

anyone got that bazooka to kill a fly idea to squash this? What are alternative options from this fragile house-of-cards palette?

After logging in, this is all i ever get hit with is "Please Enable Cookies to Continue". Cookies for the site are DEFINITELY enabled... I did that explicitly in Chrome's settings

.
Well, right after that rant I the "Cookie" method to work for the first time ever

https://github.com/586837r/node-red-contrib-alexa-remote2/blob/master/get_cookie.md

Convoluted and annoying, but alas back and running.

My message flow that I worked so hard on is now operational again... yay Monday

2 Likes

I know I saw in one of the node red topics someone had Json to convert motion sensor and switches to true/false. Anyone know where it was?
Thanks,
Craig

I have used a function node for such situations - is this what you're looking for?

if(msg.payload.value === "open"){
msg.payload = true;
}
if(msg.payload.value === "closed"){
msg.payload = false;
}
return msg;
2 Likes

Yup thanks!

1 Like

Probably something like this one (but not this exact one).

3 Likes

Iā€™m getting n a new computer, it there an easy way to backup/restore all my flows and configs

Shut down node-red, copy the entire node-red/data directory. On new server install node-red, stop it, and copy the data folder back, then start it.

I just did this last night when I moved node-red from one docker swarm to another.

Depending if you are on windows or *nix you may need to reset/update file and folder permissions as well.

Download the Hubitat app