Node-RED nodes for hubitat

Oh that's awesome!

Still didn’t work :disappointed: I’m seeing

Blockquote tpClient/4.5.2 (Java/1.8.0_181))
[15/Jun/2020:13:55:00 -0400] 401 -(192.168.1.226) POST /endpoint/hubitat/webhook HTTP/1.1 (Apache-HttpClient/4.5.2 (Java/1.8.0_181))
[15/Jun/2020:13:55:00 -0400] 401 -(192.168.1.226) POST /endpoint/hubitat/webhook HTTP/1.1 (Apache-HttpClient/4.5.2 (Java/1.8.0_181))
[15/Jun/2020:13:55:00 -0400] 401 -(192.168.1.226) POST /endpoint/hubitat/webhook HTTP/1.1 (Apache-HttpClient/4.5.2 (Java/1.8.0_181))

Doesn’t that mean it should be working?

Do you have authentication on NR? You seem receive an error 401
If so, you can look at the FAQ on first post
See answer below from @erktrek

your webhook config in NR does not have "endpoint" in it.. shouldn't it be

"/endpoint/hubitat/webhook" ??

or remove "/endpoint/hubitat/webhook" from Maker API call and just use "/hubitat/webhook"..

2 Likes

@fblackburn thx. I finally give up, I’ve done both. It fixed the log but still no update

Blockquote Jun 15:36:27 - [info] [server:Home Assistant] Closing WebSocket http://supervisor/core
15 Jun 15:36:27 - [info] Stopped flows
15 Jun 15:36:27 - [info] Starting flows
15 Jun 15:36:27 - [info] [hubitat config:Hubitatm] Starting endpoint for /endpoint/hubitat/webhook
15 Jun 15:36:27 - [info] Started flows
[15/Jun/2020:15:36:27 -0400] 200 192.168.1.154, 172.30.32.1(172.30.32.2) POST /flows HTTP/1.1 (Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_4) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.1.1 Safari/605.1.15)
15 Jun 15:36:27 - [info] [hubitat device:Led strip] Initialized. switch: on
15 Jun 15:36:32 - [info] [server:Home Assistant] WebSocket Connecting http://supervisor/core
15 Jun 15:36:32 - [info] [server:Home Assistant] WebSocket Connected to http://supervisor/core

@erktrek @fblackburn
For NodeRed Addon in HomeAssistant the endpoint is exposed differently.

From addon docs

@frmWink2Hubitat, if you decide to try again, shoot me a PM (here or over in the HA forums). I can easily set this up again and send you screenshots.

3 Likes

okay but doesn't that mean you also need to add "/endpoint/,,,," to your node-red config?

According to the screenshot it looks like you just have "/hubitat/webhook" or am I still missing something?

Thanks man but h.a has broken me. Thanks for all your help

Actually, you dont. It just need to be included in the POST url in Maker Api.
His issue may be 2 fold...entering the correct port and the correct url.

1 Like

very cool thanks.. wasn't clear from the info @frmWink2Hubitat posted. so whats the advantage to running NR in HA ? - apologies if this was asked before.

It's only a benefit if you are already using HA.

  • NR gets backed up and restored along with everything else in HA snapshots
  • NR is preconfigured with most of the HA relevant nodes preinstalled
  • NR webUI can be accessed in the HA frontend/mobile app both locally and remotely (if you have remote access configured)

Edit: forgot to mention:

  • extremely easy to install..pretty much just have to enter a few config settings and click a button and the container is built. Takes less than a minute to get running if u are familiar with HA addons.
3 Likes

This is why I love it, there has been a few times where I wasn't home and was able to dork around with some NR stuff over Nabu Casa

This is not related to HA but to Dockerised Node-RED.
I wish you well but there are obstacles to familiarise yourself with in everything technical.

1 Like

So I totally deleted the vm from scratch, deleted and reinstalled makerapi, and that worked. Thanks @stephack

1 Like

:+1:

1 Like

Now I’m scared to attempt hac. This took a WHOLE day

Ask for help on the hubitat thread in the HA forum if you get stuck.
Quick note: The Samba addon is your best friend. :wink:

2 Likes

Yes. I will agree.

2 Likes

Out of curiosity, is it legal to sell open source software?

Like could hubitat sell a beefier hub with node red already on it instead of rm. not saying they should, but COULD they?

Most opensource licenses I know of do not place restrictions on selling only requiring things like code sharing etc.

1 Like