Node-RED nodes for hubitat

For event based updates to the caches, I assume all nodes that use the device/attribute all have their cache updated on the single event? I guess it would have to, really, so probably a stupid question... :slight_smile:

Yeah events are received by the config node and dispatched to the appropriate device nodes (with the deviceId)

1 Like

I try to move token into a NR credential type (to ignore it on export and save it in the flows_cred.json). But I cannot decide myself if the application ID should be considered as a credential or not?

At beginning, I considered AppID as a username and the token as a password. But the more I think about it, and the more I think that to link token and AppID is a implementation details. I mean, having an URL without AppID could have be done on the HE side and only check the token and related internal information about it.

I know no one cares, but it's a headache for me now :sweat_smile:
Someone has hint if we should consider AppID as a secret or not?

I vote for not, but as such I am ok if it is as well.

In order of security importance to me:

  1. Token

  1. IP
  2. App id

IP and AppID aren't really that security important to me.

IP is only interesting if you have already compromised my network as they are private IPs. So I don't really care if that isn't secret, as if you compromised my network MakerAPI/Hubitat access is the least of my issues.

Knowing the AppID isn't useful without the token.

1 Like

Just obfuscating the token would be enough /2-cents

It's especially problematic on forum software like here where "deleting" a post is more a soft delete


I have been watching this thread for Hubigraph and the first thing I thought of was "I bet that could be done in Node Red."

I found a palette node-red-contrib-googlechart and thought I was well on my way. Unfortunately, it installs but there is an error triangle in the Node Palette Manager window and the nodes don't show up.

However, since there is an API, it could be done in Node Red I assume. I am just curious if anyone has tried it. Time to start researching Google Charts' API.

This timeline is the graph I really want that Home Assistant has similar and I really liked:

I use node-red-contrib-ui-state-trail (node) - Node-RED for state trail (gantt) charts.

It isn't quite as good, as it is 1 "swim lane" per node, and you can't put the label on the left (only above).

I've made a few feature requests (multiple graphs in 1 object, and labels on left) on the author's git, but I don;t know how energetic he is about adding features right now.


In the meantime for now you can use a text node on the left, and set the graph to not show its label.

Could probably do this, too. But I haven't tried it:

Well, tested it real fast, seems like it could work. Would need tweaking/work though. As-is it only accepts 2 events (true/false) per variable. So if you had something w/3+ states it wouldn't work as-is. The benefit is that this method automatically makes a new row based on msg.topic, which would work well paired w/the event node.

Would be pretty easy to take motion, contact, and switch, convert them to true/false, and dump them in the chart.

Here is an example of exactly that - just taking motion, contact, and switch - converting active/open/on to "true" otherwise "false" and dumping it to the chart. Note that the colored bars on the bottom version are all jacked up (too thick, don't line up correctly):

1st version on top, catch-all version on bottom:

That's EXACTLY what I want to do w/ motion sensors & light switches. Thank you.

Trying to decide between upgrading to a Synology to do NR or a PI 4. Suggestions?

Pi 4 would be my vote. I own both, and have used both for that purpose. If it is dedicated to node-red you really only need the 1gb (or 2gb now) memory version of the rpi.

My node-red docker container uses about 100mb memory with dozens of flows and palettes. A little bit more when loading new palettes, etc.

Synology works fine for vm or docker, though, as long as you have one of them with an Intel cpu... The non-intel Synology I've used were all kind of quirky when it came to vm or docker use.

I have a Synology ds716+ and an unused (retired) ds1815. It was my go-to device for a long time.

Anyone ever had a phantom node. When I try and deploy, i get this:

So I search for it and get this:
Notice it is not associated with a flow.

Normally, you can double-click on it and it would take you to the node but double-clicking on this does nothing but close the window.

I've tried Full Deploy, Modified Flow Deploy, node-red-restart, & node-red-stop then node-red-start but none of it works. Where the heck is it?

It's annoying to have to click Confirm Deploy every time. Any suggestions?

Is it in a subflow? It took me ages to find one in there once.
Also, there is a thing over on the right side that shows you the un-used nodes (or non-configured-correctly nodes). It could be in there.

Somehow, in addition to the rogue Chart Node, I ended up with 2 Request Nodes that were requesting all devices. That was grinding my system to a halt at Deploy so I had to find a solution.

Here is what I found in case anyone has a similar issue:

The suggestion was to open the flows_.json file and see if you can find the rogue nodes within. I searched for "Request" and got the node's ID. Then, in Node Red, I searched for that ID to confirm I found the correct node. Finally, I deleted that node in the flows_.json file. It was quick. It actually took me longer to figure out a way to open the .json file in a format I could read instead of the solid block of text that you typically see.

So, both Request Nodes were successfully deleted as was the Chart Node and then I replaced the old flows_.json file with new one.

If anyone else has a similar issue, I hope this helps.


A good moment: I successfully modified an HE device driver for a Sengled Dimmer to be way more useful in Node-RED. Adding two events ("hold" for the On and Off switches) as well as fixing it so it reliably reports actions to NR.

Looking at Groovy code I SO want to add semicolons to the end of all lines! lol

I've upgraded to the latest platform. I tried add a device into Node Red today, and could add it, but the attributes dont show up. The only thing in the device dropdown box is "All". It has attributes. I'm not sure what's going on. Dont know if it's a bug with NodeRed, or something with the new bug fix in HE??

The device in question is a HEM. There's nothing under "All". Error on right.

This is the device page.

If sending a command, the three options appear in the dropdown box, but that's a different node.

I've just tried with HE and NR 1.0.6 without issue
Can you give me the

  • HE version
  • NR version
  • NR installation method (docker, ubuntu (deb packaging), etc.. )
  • Is there additional information in your NR log file?
  • Do you have the same behavior with all your devices?
  • Do you have the same behavior with command node? no attribute in command node
  • Can you use Maker API directly? (or request node with /devices/<device_id>)

So I've got my Conbee2/Deconz/Phoscan system setup on a Pi3B+. I am actually currently running it on a separate Pi to Node Red just because I had a spare one and I didn't want to risk screwing up my Node Red setup. I am using node-red-contrib-deconz to communicate with Node Red.

After a gentle start, I have now moved all of my Hue Bulbs & dimmers that were on the Hue bridge across to it (went smoothly) and also added a Tradfri Outlet, a Hue motion sensor, an Aqara motion sensor, and some Sengled bulbs just to see how it goes. My HE Zigbee is channel 25 and my Hue was on 20 so I added the Conbee on 15 and it all worked OK. I've now disconnected the Hue so could move the Conbee to 20 if need be but it is working well, so I will leave it for now.

I'm very impressed so far. With the Hue bulbs you can set the power-on behaviour like you can in Hue directly (but can't do if connected directly to HE) and it found all of the other devices with no issues. You get a network map (like with Xbee XCTU) and it has a load of "under the hood" operations available most of which are a mystery at the moment. You can do a complete backup of the system as well. I presume that would mean if the actual Conbee dongle failed you could restore a backup to a new one. There are many more options for setting up the Hue dimmer buttons with a Hue group than there are in the Hue app itself.

As well as the deconz NR integration, it presents itself as a Hue bridge to the network so I have been able to add it directly to my Harmony Hub setup. That let's me turn on/off the Tradfri Outlet as well as any of the Hue/Sengled bulbs from the Home Control buttons.

I'm going to leave it running alongside HE at the moment to see if I get any mesh issues with the combination of repeating bulbs, non repeating bulbs, tradfri and aqara.


It seems to be an issue with MakerApi, in that Maker does not return anything for that particular device. I tried a new/different device and it works. Will give me an excuse to buy something else anyway, which I've been meaning to do for a while. So, ignore that error.

1 Like

I assume your talking about HEM??
curious to know what you go with

The consensus is IoTawatt, of which there is a good implementation with HE, but at nearly $250 US, shipped to Australia, I baulked again, and decided against. That's close to $350 AUD plus some stuff I need to buy here, just to power monitor my house. Nup.

1 Like