Node red and Alexa Web interface no longer available

I am using node-red-contrib-alexa-cakebaked to provide announcements and to play music. In the past I had to manually provide the cookie by going to the web interface and using the developers tools to cut the cookie and past it into the Alexa configuration node in node red.

Now when I go to the Alexa web interface it just has a QR code to scan and I can't find a way to get a cookie.

Any suggestions on how others are getting around this?

You can use echo speaks... It does require an rpi though.

I think this is the fork that is current and still under development (I don't use any of them).

1 Like

I use it and applestrudel is the latest.


@stephen_nutt Does applestrudel use a cookie for authentication? If so where/how do you get it? Thanks

Mine has always been setup to use Proxy as Auth Method but it looks like Cookie is an option. Since I have only ever used Proxy, I can't answer your question.



The proxy method logs in and gets the cookie for you.


node-red-contrib-alexa-cakebaked also has a proxy option to authenticate, I thought I would try that before deleting stuff. it offers the localhost:XXXX (username & password), it then sends, by test, a 6 digit code to enter. the code will not enter the box, it does a weird self clearing, it doesn't authenticate. Do you think this going to be different with Applestrdel?

Sounds like some sort of browser issue, so yes the same may happen with the other version. Its been a long time since I logged into it, has been working ever since.