No Success with Hubitat so far

I have had issues with hubitat keeps slowing to a crawl. all i have is now about 10 zigbee devices only. I have moved my Tado Thermostats off Hubitat and moved them to Homeseer. so its doing very little. i send the status changes on the zigbee devices to homeseer via custom smartapps.

I updated to the latest version a few days ago and since then the slowdown has got worse. It was completely locked up this morning and now after another reboot its now asking me to set it up afresh.

so presumably now i have lost my zigbee devices.

not really happy TBH

yup confirmed, i have lost all my devices and smartapps :frowning: not sure i can be bothered setting this up again

edit, it has recognised my backups, so i am attempting a restore now.

ok Database failed to restore is the result :frowning:

I must admit that after initially being really pleased with my Hubitat, it too has started to become sluggish. It can now take several seconds for actions to perform that initially were virtually instant. I have tried rebooting but it's not improved much, if at all. I have added another Aeon Multisensor recently making 3 in total on the system, but they are only set up to report every 5 minutes so I would hope that's not too much of a drain on resources. I only have about 20 devices in total, all Zwave. Sadly this is what happened with my old Veraplus, it started OK, but became increasingly unreliable and sluggish. I really hope Hubitat isn't going the same way.

yup i've tried all the solutions, the only one that has been rock solid for me has been homeseer, zwave devices and complex automation trigger in seconds. I have been from Smarthings to OpenHab to Zipabox to Vera to Homeseer with Smartthings (for Zigbee) now Homeseer with Hubitat, i now have over 200 physical devices and an equal number of cloud/virtual devices but for the Homeseer stuff it triggers very quickly without slowdown and i have been using for a long time now. but it is sadly lacking zigbee capability, and the interface is so 1995 :slight_smile:

i've emailed support so let's see how this goes, i like the idea of the hubitat hub, its an impressive feat what the guys have achieved with off the shelf components, but the hub itself is an android tv box which retails for about £30 here in the uk. the thing im thinking is that the processor just doesn't have enough grunt. may be wrong. but IMHO homeseer running on a raspberry pi 3 which im probably betting has similar processing power ends up maxing out at about 50 devices and 4 -5 plugins.

I used to use Homevision Pro, that was very 1975! But the system itself was super reliable, built to aerospace industry standards apparently, with IR transmit and receive, and input/output ports built in. Even X10 was pretty reliable. If X10 had been a 2 way comms system I think I would still be using it now.

1 Like

i'm just investigating the possibility of using deCONZ for zigbee. just need to know if it works with this zigbee usb stick from Hubitat. if so iam set and i will create a plugin for homeseer

I've noticed that my hub is starting to get sluggish as well.
Sometimes it takes around 5 seconds to turn a light on when a contact sensor opens. It used to be lightning fast.
I haven't added anything recently that could be the cause.
Tried a reboot but it does not solve the issue.

1 Like

Well the HUSBZB1 Device does not work with deCONZ, however thier Conbee usb stick is currently for sale for £35 on amazon, so have just bought it, there is a lot of interest for deCONZ plugin on Homeseer forums. so might be a bit of a cash spinner if i can get a plugin working, and after just getting a new Tado plugin up and running (that is far more reliable than what i have down for smarthtings/hubitat) for Homeseer. im after a new challenge and if i can get my single box also supporting zigbee, my HA life is set :slight_smile: and i can earn some loot in the process too.

@bobbles thats a shame as i know you had high hopes for Hubitat. i wonder if how many others are affected. seems so far it's us UK users....maybe thats a theme for them to investigate

I do have everything running on webCoRE pistons so maybe that could be the issue.
I'm going to convert a few pistons to Rule Machine and see if things improve.

@bobbles i doubt that is the issue, i don't use web core, and as of recently i now have only 1 rule machine rule and a couple of smartapps that subscribe to device events and sent web request, my hub has got to be one of the most underused out of everyones, and if it dont work for me it aint for anyone

1 Like

Hopefully support will be able to track down the issue for you. It is most likely a rogue app or driver. I had a very simple one that brought my system down too. My fault, trying to port over a driver to work with my new Axis shade controller. One little line of code is all it took. Easy fix though and everything came back to life.

For reference, I have 146 devices (18 zigbee, 38 Virtual and the rest z-wave) running smoothly on the Hubitat. I also install just about every app that comes along and then delete the ones not useful to me. But I love to tinker, so I'm always messing around with something. Right now I have 13 aps installed (need to delete a few I don't use!). I also have webCoRE installed on a RPI with about 30 pistons controlling all the lights in the house. Everything is based on motion, time of day, temp, etc.

With all that said I am more than impressed with HE. I was a HomeSeer Pro user for over 10 years, then moved over to ST and now on HE. HS was/is a great product but falling behind fast with the interface and not getting on board with zigbee. I guess they are waiting for another user to develop it and then charge another $40 to $100 just to use it (Insteon anyone...). Then you have to hope that the user doesn't disappear and the plug-in just fades away. It happened to me too many times. If it wasn't for Blade (BL Plugins) I would have left years ago.

But again, I would definitely take a look at your app and/or drivers and try to eliminate each of them, one by one.

The thing is the it can't be the smartapp or devices i'm using to send the web requests for status changes as i had them installed since day one and they havent been changed since.

The slowdowns started maybe 3 weeks after using Hubitat and no changes were made after the first 3-4 days of ownership after setting things up and porting my smartapps to the platform. but rebooting would resolve

and If anything 5 days ago i deleted my Tado and Netatmo smartapp ports along with 31 virtual devices.

I now have no custom drivers in use, only included. and no smartapps other than 1 smartapp (slight variations with the events it subscribes to) but as stated 0 changes and been in place since day 1, with 0 changes.

I did also update the Firmware 3 days ago as it stated more stability enhancements and since its just been worse, stopping every day. now it's just died and it would not restore a backup and now stuck at 10% after a restore attempt.

but i'm not a tinkerer on this platform. i do however dislike i have no access to the console to troubleshoot directly in this scenario. waiting all weekend for support is just not viable IMHO (well especially for those with whom this is a main component of the platform.)

one thing though, you are not UK based. you don't have the 2 USB stick solution. maybe that is some commonality? the others in this thread complaining are all uk based.

The lack of zigbee is an issue for Homeseer that is true, but i think i can interface with deCONZ easily enough which would tick a lot of boxes for me. and as for paying for software, i pay for software all the time that fades away, that is part of life. but if i have a reliable solution at the point of sale im not too fussed about making that payment. it is usually just $40 max for some of the better and more fleshed plugins. and that i don't have an issue , if the shelf life of a software product is going to be a minimum of 2 years or so.

but i do agree homeseer needs a decent FE for it. but i use Imperihome for the minute which is great for my needs.

but what i don't get is what interface does Hubitat have? the dashboards IMHO aren't information dense enough to fit a decent amount on a 7" tablet

as for without dashboards the web interface looks old but with the filters its quick to find what you want and the controls are right there

and my home wall dashboards look like this with Imperihome.

the more i move on, i think the HA solution should concentrate on backend and reliability and have FE development done separately as is the case with Imperihome

Thanks for bringing this to our attention, I know Bobby has reached out to you to help you get your hub up and running and I'll work with you to find out what is slowing down your system.


I am in the same boat as Fuzzligic.

My Hubitat is running firmware version (latest available for me so far) and after a day it goes to a crawl and becomes totally unresponsive. The only way to have it online is powering it back to life.

I have a support ticket opened about a week ago but I am (unfortunately) almost moving my devices back to Smartthings due lack of a workaround.

So, I don't mind running beta code as long as it fixes the issue. Any idea when I can have access to a fix/workaround?

my hub has been reset and i am at the moment up and running again, looks to be responsive now. will keep an eye out for any further slowdown.

Support just contacted me (working on a Sunday! Wow!) and maybe my InfluxDB app could be causing some issues.

I will delete it for now and see how the hub reacts.

Keep you posted.

yup @bobbyD has been working hard today :smiley:

1 Like

Someone buy the guy a beer!


Ha! We are all working hard around the clock. We live and breathe this business. There is no rest for the wicked...