No response in HomeKit

HomeKit integration has been working great since I purchased Hubitat hub in December. Tonight out of the blue all Hubitat devices stopped responding in HK. I’ve not changed anything lately either in HK or Hubitat. It just stopped responding. I’ve rebooted the hub several times as well as my router. Is there a problem with the integration?

The integration is not cloud dependent. So if it stopped working, it is because something on your LAN isn’t working the way it used to. I would suggest rebooting in sequence:

  1. Your router and switches
  2. Your Hubitat hub
  3. Your HomeKit hub
1 Like

Thanks for the input. I tried exactly as you described but the result is the same. I also forgot to mention that all devices still respond accordingly within the Hubitat UI. They’re just not showing as responsive in HK.

What is your Home hub? Apple TV or HomePod?

UPDATE

My Apple TV was acting as my home hub. When I rebooted everything per your guidance I did a restart on the Apple TV. Once it restarted it was still listed as the connected home hub and I still had the same problem. However just now I decided to unplug the power cord from the Apple TV and force a HomePod mini to take over just for the heck of it. As soon as I did that the Hubitat devices came back and started working normally. Not sure why that worked but it did. Lesson learned. Thanks again.

2 Likes

What version is your apple tv on?