[No longer maintained] Rheem EcoNet Integration

Me either so I haven’t really dug into this. I haven’t been able to reproduce the problem. I’m curious if the workaround posted a few posts back does for anyone with the issue?

1 Like

I don't check my hub daily, but apparently the issue fixed itself between when I last checked and when I posted earlier. So... who knows?

I was getting the lost connection to MQTT, retrying in 15 seconds error. The hub has been rebooted since the last time I noticed it so maybe that fixed it.

Sorry to be dense, but which post are you referring to?

this one, [RELEASE] Rheem EcoNet Integration - #200 by brianspranger

I just started getting the MQTT error as well.
Is anyone able to confirm that the workaround posted above works?

I’ve been unable to solve it using the posted method.

1 Like

Is there any way to get the current status of the water heater? e.g. Is it actually heating (ON). All I see is “idle”.

I’ve been using your integration for nearly a year now, and THANK YOU.

Using a gas water heater. I know it’s been 2 years since your original post, but I’m happy to test something if you need.

Not sure if that’s a limitation of the gas heater. My hybrid shows the thermostatOperatingStateas heating. Does what hubitat says differ from the rheem phone app?

Would it be possible to get description logging added somewhere and not just debug logging? Probably for the virtual device that gets created. I would appreciate that.

The Econet app always shows “Heating” no matter the set point. So, no, basically the app and Hubitat show the same.

I really do hate that they have neglected the gas water heaters from the beginning, to the point of removing what little practical functionality existed. If I had known, I wouldn’t have bought a Rheem to begin with.

Same here. The gas water heater is functionally useless, except perhaps for the leak sensor. But a zigbee sensor is cheaper and more flexible.

I wonder if there is anyone that would be willing to take over this app?

If I had the time and patients to learn the coding of these apps, there are a couple I would love to start maintaining, but sadly I am awful at coding, BUT, I totally agree with ya, I wish someone would pick this up too.. I love the basics of the App integration, and, to date, it has been working flawlessly for me, minus when Rheem's connection goes down.


I could perhaps take it over, I'm buying a Rheem water heater tomorrow. I'm also familiar with AWS IoT Core, which I believe is the heart of their platform.

Without reading the whole thread, can anyone give a list of what currently works, does not work, features that you want to see added, etc?


It works as-is for my gas water heater.

Update:The current (old) Hubitat driver does NOT work "as-is", at least not anymore. I just checked it again and it doesn't set the temperature like it used to.

1 Like

If you look around message 196 in this thread, you’ll see a few people (myself included) reported a repeating error message spamming the logs. Some folks seem to have solved it; others not so much. Mine was spamming 7x24 so I had to deactivate the app. Would love to get it working and am happy to be a beta tester if helpful. Appreciate your offer.

Mine seems to be working fine and has been since I got my water heater. I'd be interested in what @klinquist could do with it lol. Thanks in advance if you do.

1 Like

Me too, other than bug fixes and making sure it stays updated, not sure what additional features I could implement.

1 Like

@klinquist That would be plenty enough for me. I just installed the app for my heat pump water heater and it seems to be working well - no log spamming so far.

Ok, I can see some neat things I can add. Just got this packet over the Rheem MQTT device topic


Ambient temp, lower tank temp sensor reading, power usage...
Don't k now what all the fields mean (yet)...