No control of switch when using iphone app

I am using a Leviton plug-in switch to control an electric fence. I have the switch set up on automation to turn on at a specific time and then shuts off at a specific time. It works great on automation. However, when I open Hubitat on my iPhone or on my pc laptop, the tile to turn it on or off always shows that it is on even when it's off and I have no control over the switch. If I select the tile to change the current status, it just goes into "sending", changes color from yellow to gray and it locks up and just stays in that sending status. I have a range extender that helps out and when doing a repair of my hubitat, it shows the path that switch uses to communicate. Why doesn't the iphone or laptop have control of the switch?

Thank you for your fast response. I used the plug before out in the garage and worked perfectly out there. Looking at the back of the switch it says Zwave plus.

1 Like

Ignoring the dashboard for the moment, does the switch work from the device page? If it works from the device page and not the dashboard, delete from the dashboard and recreate. If it doesn’t work from the device page then you made need to add a repeater or two.

1 Like

Thank you, no it doesn't work from the device page either but never misses when the app or simple rule I created turns it on/off. Well, let me rephrase that. When I initially set it up and created a simple rule, the on/off on the device page and the tile works. But then 15 minutes later, neither the device nor tile icons work. I have 2 range extenders and one even in the same room but after doing a repair network, I can see the path taken and the route taken doesn't use the range extenders. They are Aeotec range extender 7's. The 2 devices it uses for the mesh are not near or in line with where the hub is to where this plug is. Is there a way to force the hub to use a specific range extender or another device when creating the map/mesh it uses? Thanks

No, there isn't.

However, if you are on a C-7, you can do this:

  1. Unpower the two devices that it uses to communicate with the hub.
  2. Then, run a z-wave repair solely on the node corresponding to your Leviton outlet.

When the repair is done, plug back the two devices you unpowered in step 1. This should help the Leviton outlet find a new path to communicate with the hub.

If you're on a C-5, I would recommend excluding the Leviton device, and then re-including at its current location.

1 Like

I have the C-7. That’s ingenious. Thanks you so much. I’ll try that.

1 Like

What exact device is this (model number)?

What driver (Device Type) is this using?

Here is an update. I removed the Leviton switch again and reinstalled it. Then I did a network repair and noticed there were no other devices used to communicate to the switch. IOW no mesh. Now the switch works extremely fast when turning it on/off with the tile on the dashboard or in devices. The mesh it created before was the problem. It used 2 devices to try and communicate with it. I wish there was a way to manipulate the mesh devices so you can try a straight connection first. I was planning on unplugging the mesh devices it was using on the reset but never got to that because it didn't use any this time around. I learned a lot on this one.

Leviton DZPA1-2BW Decora Smart Plug-in Outlet with Z-Wave Technology, White, Repeater/Range Extender

I am not sure what firmware you are on now, but there is an update for these that might help reliability. Leviton seems to have issues for some users, these updates seem to help many of them.

You don't need a Z-stick or Homeseer like they mention in the link below, Hubitat is capable of updating these with the built in updater app. Device Firmware Updater | Hubitat Documentation

This update will bring you up to firmware 1.23. You will need to download and extract the OTA file, and upload the one for your device to the hub following the instructions in the document above.

Well, I think it's unrelated but after several years now my C-7 hub just now died. No green light or any color light. Just ordered a new one. Tried several other plugs in the house and no light. Hooked up another usb charger that is 5vdc and still no light. I keep everything updated when it comes out.

Neonturbo thanks a lot for that info. I have a new C-7 I'm just finishing up and tried to update the firmware to the Leviton switches . I have 3 of these Leviton switches, 2 at 1.15 and 1 at 1.17. I tried the update to 1.23 and the progress bar is still blank after 1 hour. It says it's uploading but no progress. I have the correct firmware for my model, DZPa1, and it ends in .exe.

You want the OTA file. Did you extract the file?

I have never updated these devices (I don't own any Leviton) but most devices I have updated take at least 30 minutes to an hour to update, so be patient once you upload the correct file as noted above.

I downloaded the Leviton file and expanded it in a zwave firmware file I created on my C: drive. Then expanded/unzipped the file in that folder. Then picked the DZPA1 file and expanded that. All files are .dll except for 1 that is .exe. I expanded that and it created simple program to change your firmware but no where is there a place to find any files on it. No where do I see any file with a .ota. Strange

DZPA1_v1_23_ota__TargetZwave__.exe

Here is that file I tried to upload in the firmware updater on the C-7. Everything else in the folder is .dll. This file has ota in it. It did download into the C-7 but it wont change the firmware when I select to update the firmware.

Download the Hubitat app