No Buttons are working


I have two Scene button device types. Two Enerwave ZWN-SC7 devices and two Zen32 Scene Controllers.

If I setup a Scene in the Groups and Scene app, it doesn't let me pick the Zen 32 devices as a button to trigger the scene. So I picked one of the ZWN-SC7 devices to trigger the scene. I picked button 1.

When I press button 1, nothing happens. I looked at the device Events and it showed that button 1 is being pressed, but the scene isn't triggering.

Also, I tried using buttons to set Modes. Whatever buttons I set on any of the devices didn't seem to trigger the mode change.

I am new to Hubitat. Former 12yr Vera user. I "upgraded" to Ezlo and decided to start looking elsewhere. Happy I found Hubitat, but I need to get some things sorted out!!

Thank you!

What option are you talking about? Do you mean "buttons to push upon activating scene"? If so, that option does not work like that--it's sort of the opposite, (virtually) generating a button event on the selected device when the scene is activated. Most people probably don't have a use for this option, though I think it might be useful for Lutron users.

What you want is another app to activate the scene based on the button push. Button Controller (for complex automations) or Basic Rule (for simpler things) would be my recommendations on where to start, though there are lots of options.

Not sure about your mode thing, but sharing the setup you're using there (what app and how it's configured) might help you get better advice.

Good luck!

In the mode manager this is what I have set.
"Set modes with button device"
==> "Set Away mode with this button device"
==>selected one of my Zen 32
==> Button number for device - I put #4
==> Pushed or held - I selected Pushed

I understand what you are saying about the buttons to push thing....I get it now. So I will have to look at the Button Controller app. Will try out and report back.

So, I was able to get the Button Controller setup. At first the button didn't work when I configured it the other night. This morning the button works fine. I will try out the other buttons.

Still not seemingly having any luck getting the Zen32 or the Enerwave device to trigger a mode change.

Is there something I need to do to get the Button rule to apply to the Enerwave device? Like does Hubitat update the switch at somepoint?

I have a Go Control Device and if I configure button rules they seem to apply immediately.

I tried an Enerwave that I didn't program before. I added a scene to button 1 through the button control app. Success. It worked right away.

So I went to add more buttons and I noticed that if I make changes or add actions in the Button Controller App for the Enerwave device the red "(Not Installed)" indicator doesn't pop up like it does for other devices. If I delete the button controller for that device and re-create it, the "Not Installed" shows up each time I make an action. I finished all the updates and went and tried the Enerwave device. None of the buttons worked as programmed, except for button 1 which I programmed the first time.

Did you hit "Done" after adding the app? That will "install" it and is all you should need, and it's also why that won't appear again after you do this for the first time. I would continue to hit "Done" so that the app creates subscriptions for the button events (which will wake it up when the event in question happens), but with Button Controller 5, just doing that in each "grandchild app" (button event) might be enough, rather than the entire child app, though that can't hurt...

Thank you for responding.

I deleted the Button Controller child app for this device. I then removed the device from Hubitat. I reset the device. I then added it back as a new device. I then went back into the Button Controller app and created actions for all 7 buttons. Each button grandchild rule I would go into the "Not Installed" would pop up. I'd program the action to call a scene, click done, click done and the "Not Installed" goes away. I 'd go to the next button, etc until done with all 7. I then clicked done in the Child app which took me back to the App page.

I tested button 7. No luck. The switch flashed all buttons indicating that button wasn't programmed. I clicked button 1 and it responded as programmed. None of the other buttons are programmed.

This is a similar state to my other Enerwave. Only button 1 scene seems to work.

Button Controller won't make your real-world device flash or not (I am not familiar with this device in particular, but that is not a role that Button Controller plays--it will just respond to the button event on Hubitat and run your specified actions). So, I'm not sure what this means for your device.

Have you verified that the button events you are expecting are actually being generated on Hubitat? If you leave "descriptionText logging" enabled for the device (as it is by default), then you should see entries in "Logs" for events, including things like "button 1 pushed," for that device when they happen. (That being said, the "Events" button at the top of the device page is technically an authoritative source, but any driver with this option should write the same to "Logs" as it happens.) If this doesn't happen when you expect--or the button events are different than you thought--then that would explain the problem, even if why that is happening is another issue.

So, I am in luck!! I was reading a post about the driver created for this old (but fantastic) device. I went back into the device and hit the configure button a couple times. The buttons are now working! Also, the logs are populating.

Tried this on the other device and I am making sweet sweet progress! Now the fun can be had.