No action from Pico remotes

Welcome to the Hubitat community!

Please clarify. Are you trying to use a button in an app like Button Controller? Are you hoping that the Pico is joined with a Caseta automatically? Other?

When you set these up in Caseta app, did you put them into their own "room", or in the same room as a Caseta dimmer?


How are you generating these digital presses, and how is the automation/app configured on Hubitat (i.e., the thing that it is supposed to be doing)? It looks like the events are coming through fine, though the "Events" tab/button on the device page is the authoritative source (it's up to the driver to make the log entries, but it's not under control of the platform and there could be a discrepancy). This would leave an event subscription issue on the app as a possibility.

But it's hard to say more without knowing your particular configuration.

1 Like

Thank you very much for the responses. I'm on night #1 with the system so forgive my ignorance.

My goal is to control whole-house scenes from a 4 button Pico remote: PJ2-4B-GWH-L31

I have two of these Picos currently added to my Lutron SmartBridge Pro 2: one that controls all lights (on multiple Caseta switches) in my kitchen (setup through Caseta app) and another is completely blank.

As part of my initial setup, I tried testing button presses through the Devices tab for the Pico connected to the Kitchen. I tried inputting buttons 1-4 (based on what was showing on the activity log, previous screesnshot) as well as 8-11 as shown from my Integration report. None of these approaches were successful.


I am, however, able to control the lights in my Lutron system through the Devices tab.

Is there anything else I can provide to add more context?

To be clear, Pico button presses are one-way traffic from the Caséta Pro bridge to Hubitat. So button presses from the Hubitat device page aren't sent back to the Caséta Pro bridge.

The ability to Push/Hold/Release specific buttons from the Hubitat device page is to test the effect of those actions on Hubitat automations.


That's somewhat surprising since the below LOOKS like the same thing should be happening in the kitchen but clearly not the case.

Hubitat Log

Maybe I'm then looking at this wrong and should just skip to my real question which is how to program Caseta scenes to Pico button presses? I feel like I've searched for every iteration of this question but have not been able to find the answer.

IIRC, Caseta Scenes will show up in the Integration Report with specific ID of # 1.

Using Hubitat’s Lutron integration, if you add this device as a Lutron Keypad, ID 1, a new Hubitat device will be created that can be used to trigger Lutron Scenes.

Once you have this device created, you can use a Pico to trigger an automation to “push()” this Lutron 100 button device with whatever Lutron scene # you’d like.


I have never used the Caseta scenes, any scenes I have set up have been in Hubitat. While it is theoretically possible to use Caseta scenes, I feel they are more limited than using Hubitat. You can use that Hubitat based scene in Button Controller, Basic Rules, or other automation apps.

1 Like

Yup - this is the way to go - it is very fast:


In the Lutron integration app, you would add it as something like:

k,1,Test Scene

Which will create a Hubitat Lutron Keypad device. Pushing button 1 in that device will trigger the first scene etc.

And you can use a Hubitat automation to map that push to a particular Pico button.


@motion732 @aaiyar is giving you the correct format, so you should see something like this...

k,1,Smart Bridge Pro Scenes
d,2,Javi's Bedroom Mains
d,3,Finn's Bedroom Mains

When you set your scene in the Lutron app, run the integrator to find the button it's using and you will set up a button like this

1 Like

Thank you all very much. Everything you've said is making perfect sense however it's still unfortunately not working.

Here's the setup. From the integrator report:


4 button keypad added in devices;

Smartbridge2 added in devices:

Button rule:

However when I push button 1 on the 'nook' keypad nothing is happening =\

Sorry for being so dense with this...

how is the integrator on hubitat looking? You set up the k,1,integrator name correct? All lower case? It's showing as a device in the devices page? Like this?

1 Like

Seems to be there without issue:

Did you confirm that this device works as expected from the device page?

@motion732 Your rule seems to be off... Make sure it looks similar to this (specifically button 3) Also turn on debug on the keypad device and pico and see what the logs say when you push the pico button. Open the logs on a separate page.

That "Nook" device should be a Pico as Pico buttons have different numbering mapping from keypads.


Button controller:

Events from the "Nook" device show the button is pushed:

Now when I digitally push "Smart Bridge 2" button 2 from Devices tab the scene goes on. There seems to be a disconnection between the Nook Pico not triggering the command on the Smart Bridge 2. What's interesting is when I press the top button on the device, which I would think is button 1, it's showing as button 8 in the log. However, if I digitally press button 1 OR button 8 on the Nook, nothing happens.

The issue is that the Pico remote was added as a Keypad, instead of as a Pico. On the Hubitat hub, remove the Pico from the Lutron integration, and then make sure it has also been delete as a device on your Hubitat hub.

Then, go back into the Lutron Integration app on your HUbitat hub, and add the Pico remote as a Pico, not as a Keypad. The 'Keypad' device is only valid for the Caseta SmartBridge Pro 'Scenes' device, ID 1. On a RadioRA2 system, 'Keypads' can also be used for true RA2 keypad devices. But Pico remotes are always added as Pico remotes, regardless of whether one is using Caseta or RA2.

Removing and adding the Pico correctly as outlined above should resolve this issue.


Thank you! That did it! I appreciate all of your prompt support!


I'm embarrassed. I didn't even spot the keypad driver issue in the pico.

Ugh Frustrated GIF by Equipe de France de Football

1 Like

Well, I had it as a Pico initially but up earlier in the thread it seems it was suggested to be coded as a Keypad. Anyway, now it's working!

1 Like

Download the Hubitat app