Newbie - cannot add first device

I am completely new to home automation. I have the Hubitat C-7. I have tried everything I can find on the forums to find device for my Zwave plus dw-zwave2.5 ECO contact sensor. Ive tried Include, exclude, battery out and back in, cover on cover off. Everything it just says "Looks like you're having trouble including your device. Please try excluding it before attempting to include the device again" I've done all of these things for 3 hours now with 3 different Zwave plus dw-zwave2.5 sensors. Please help before I go crazy.

Have you seen these instructions? Join and Reset Instructions - Hubitat Documentation Do a factory refresh first on them. Also, make sure you have not created any ghost devices. Go to Z-Wave details and look for devices that have missing fields (I forget which ones.)


Hi Jamesislate
Thank you for replying. This device has no factory reset. This is the first device I have tried to pair the hub. When I try and go to Zwave details nothing happens. I assume because there are no devices connected to the hub. Any other advise is appreciated.

Being that this is the first device you are trying to include, please be sure to drop an email to so we can make sure your radio is functional. Other suggestion is, to bring the device closer to the hub, if you didn't try that already.

You mentioned that you have tried to exclude the device. Have you seen the confirmation that an unknown device was excluded?

1 Like

If you don't have any devices your ZWave details screen will look like this (hub version is that what you're seeing when you click on ZWave details?

Once you have a few devices in there it will look more like this (with different device details of course)...

Just above that on the right, there is a toggle to turn it on or off.

Hi BobbyD
Thank you for the reply. I will email them in a few minutes. I have tried all the sensores seperately only inches from the hub.

When I go to my log it says:
Zwave exclusion started for 30 seconds
Zwave exclusion stopped
Zwave discoveryrunning
Zwave discover stopped
I see this over and over and over again but no conformation that it was excluded.

Thank you for the reply. When I go to Zwave Details it just searches for a while then I get a "Error 500 a server error has occured" so something is wrong I just have no clue what.

OK. That ain't right. I wonder if it would be worth doing a soft reset just to be sure? I'm not sure this will help but at this point I don't think it will hurt, either. You can access the hub's diagnostic tools menu at http://[your-hubs-IP]:8081. You'll need the MAC address of the hub to use as a password and then you'll have to manually type the words "soft reset" when prompted. This will essentially wipe the hub clean (since you don't have any devices paired) but that shouldn't be an issue since the hub is brand new. Beyond that I think we'll need to engage support.

1 Like

Thank you Brad5!
I'ii try this. I have emailed support also describing the issues Im having.

Unfortunately soft reset did not work. I just tried Zwave Details and it still goes into Error 500. The exclude and include is doing the exact samething. Im super frustrated. I hope this is not a normal Hubitat experience when trying to include Z wave products. I have a few more on the way and dont want this experience for every device.

Given that your issues seem to revolve around the zwave side of the equation, you may want to try a shutdown of the hub, and then remove power (at the wall plug) for about 30-45 seconds. This should reset zwave and wipe any cached information.

After that, if you can get to the zwave details screen, check to make sure that it shows zwave as enabled.

If you are still stuck at that point, then it’s probably time to call in the resident zwave wizard @bcopeland.

1 Like

Thanks thebearmay. I just tried the shutdown and unplug when safe. I still can not get into the Zwave Details. It just searches and searches then after a while I get the Error 500 again.

@jeffpridgen please stand by we've got your ticket and we are investigating. Have you performed a Soft Reset as suggested above?

1 Like

Thank you BobbyD!! Yes I have performed the soft reset.

Please check your email. We believe that you are dealing with a hardware malfunction and will need a replacement.


Email has been sent. Thank you for any help you can give.

I got a wierd response when replied to your email. it said it does not recognise replies to this ticket? Email below.

Hi there,

Thank you for your update. Our system does not recognize replies to this ticket, so you will not receive any further response. Support will reach out to you if additional details about this incident are needed.

In the meantime, you can find user documents at

Also, Hubitat Elevation also has a very active community with many friendly members ready to offer assistance. Search answers or post your own at

Here is a summary of your ticket:

So I sent it to your email. Let me know if you did not get my email response.
Thank you BobbyD

You can ignore that :slight_smile: I've got your email. Thank you...

1 Like

Thank you!