New User; Hubitat Cannot Discover Yeelight YEELIGHT Smart LED Bulb, Multi Color Rgb

Hi All,

I am migrating from Wink to Hubitat and so far, so good; I am up and running with 4 Lutron Caseta switches using the Pro bridge and have 4 z-wave switches installed as well. For the life of me, I cannot get my Yeelight smart color bulb (YLDP04YL) paired in Hubitat. I am certain the Yeelights are connected to the appropriate network and they are connected via the Yeelight Android app no problem. I have also made sure that the Lan switch within the Android APP has been enabled.

All that happens when I open the Hubitat Yeelight Integration app and attempt to discover the Yeelight is......NOTHING! I have tried and tried over the space of time as long as two hours and there is no connection (discovery). I believe I am doing everything correctly per all the previous forum posts I have read on this topic.

Any tips or insights? I feel I am so close yet so far from success here. Thanks so much!

@bobbyrab I had the same issue until I did a manual reset on the bulbs. I removed them from the app, did the reset by turning them off then 5 on and 5 off each 2 seconds apart until they blink.
Also, I reset and added them one at a time back to the app and renamed them there just to keep track of where they were. The app will see them as a number. By renaming them in the app you can look at their device properties and see what number associates with that name you gave it.
Then I restarted the Yeelight search. The app should should see them fairly quickly but it can take a few minutes.

Thanks for the quick response. When you say you reset them one at a time "back to the app", do you mean the Yeelight app or the Hubitat Yeelight integration app. Do you first have to discover the bulbs in the Yeelight app and THEN do the Hubitat Yeelight app discovery process??


@bobbyrab First I reset each bulb one at a time. The I let the phone app discover it. Then repeat for each bulb. You can write down the last two numbers of the bulb so you can recognize them as to where they go. The key to the reset is to make sure they do the blink. Then after they are all in the phone app then you can go back to the Yeelight Integration app and start the search.
Hope that helps.

Thanks, will give this a shot later in the day; I am spending my entire life on Hubitat it seems!

@bobbyrab Welcome, I know the feeling.

@razorwing OK, I just quickly tried your procedure to the "T" and I did connect again to the Yeelight APP but again, it was not discovered by the Hubitat Yeelight Integration App. One thing I did notice was that when connected the bulb to the Yeelight app, I got a dialog warning box in Yeelight app saying that Yeelight was attempting to turn wifi on/off, and should I allow or deny. I allowed and process stopped and I had to allow again, and the wifi connection ultimately succeeded but the process did not one in one continuous step. Maybe THAT is an issue? As I said, it did connect the bulb to the Yeelight app but I cannot discover it in the Hubitat Yeelight integration app still. Weirdness huh?

@bobbyrab One other thing you can try is to remove the Yeelight Integration App from HE, reboot the HE hub, then re-install the Yeelight Integration App again and try to search.

If that doesn't work there may be a deeper rooted problem that someone else with that understanding will have to help.

@razorwing So far, no luck in discovering the Yeebulb on the Yeelight Integration App. Very frustrating!

OK, I finally figured out how to discover the Yeelight in the Hubitat integration app. Of course you have to enable LAN control in the Yeelight Android app, but THEN, you must click "Third Party Control Protocol" at the bottom of the screen and the next LAN control screen will refresh. Only then can the Hubitat discover the Yeelight. Whew!

1 Like

@bobbyrab That's new having to click on the protocol thing. I don't recall having to do that. So you may have discovered a bug in their app. Glad you got it to work.

yes i find Third Party Control Protocol but i do`t find hubitat hub ? bobbyrab can you help me ?

Did you have to download anything else? I just clicked on the "third party control protocol" at the bottom and it took me to a webpage with this on it. But download doesn't seem to do anything.