New to Hubitat, Coming from SmartThings, Confused o.O

Hey guys,

I'm trying to move from smartthings over to hubitat. I really only have outlets with buttons to use in place of light switches as the way the house is laid out is not very good.

I added a smartthings outlet successfully, but it doesn't show the voltage which I actually used regularly and I'm not sure how to get that to work.

I also tried to adding a smartthings button, which shows up as a contact sensor, and the open / close doesn't match when it is pressed. It also doesn't seem to do anything different with single press, double press or long press. How can I go adding a button?

Thank you,


For the ST plug

I don't have any ST button, sorry

Hello @vjv,

Could I ask why device type you choose? Even if I turn that on, I do not get a power value.

I tried to post an image showing my dashboard but it says I'm not allowed to put images in a post...


That's the exact same as mine. Is there something else I need to do other than setting the "Enable automatic power reporting" value?

Nop, but depends what you have connected, if you have something that consumes 3 watts but you have the setting on 5 watts then it will stay at 0 power. Did you test with 1 watt first?


I actually didn't plug anything in because I thought it would show 0... :frowning:

Now to figure out this button thing.

No problem, welcome to Hubitat!

Thank you.

which button?


The smartthings button. I think there is only one.

If I have the type set to a generic contact sensor, a single click opens the contact and a double click seems to close it and I can make a rule off of that.

But with SmartThings you have single click, double click and long click and I had automations setup to each of those.

I don't think a generic contact sensor is the right type but that's what it is detected as and nothing else on the list really works either.



I have the Samsung (samjin) version of device and wrote the driver for it, which is Samsung zigbee button in the drivers type list.
Maybe this an older one with a different fingerprint?
You can try using the above driver, hit configure after replacing it and let me know.


I can't believe I didn't see that in the list. Mine also says it is the samjin version. I bought it from Best Buy maybe one or two months ago.

And it paired as device?, and not the driver i mentioned?

Yea it paired as a generic zigbee contact sensor.

Much like the smartthings motion sensor I'm trying to add. That must be the default device type.

Yeah it is, I thought we pretty much had every centralite, st and Samsung Zigbee device covered.
If you want to help out with fetching the fingerprints I can get them added to the drivers and the next person with these won't have to hunt and peck to get the device working.
For zigbee devices the complete fingerprint is only available by selecting the more button in the device pairing screen.
If you paste that text here, I'll update the appropriate driver.


Just choose the correct device type. It paired like that for me too. It's loaded in the list. just pick it. Also Advanced button controller is the app I'm using for the button.

Hope this helps you for the button.