New to Hubitat. Bad lagging on dashboard

I am very new to Hubitat. I actually just set up a new hub and added a couple z wave switches. My issue is that the switches added very fast and show up on the dashboard. The issue is that the just don't work correct. They are not showing the correct feed back for the status of light. Also if the light is switched on by the physical switch, I can turn it off by the dashboard fine. An hourglass appears on the tile. It seems to never go away. I can't use this tile anymore unless I physically flip the switch again and start over. I just dont know if there is a setting that I am missing when setting up these switches.
Also if I go into the device I can operate it very rapidly with NO delays.

Any help would be greatly appreciated.

Welcome to the Hubitat forums!

  • Can you start by telling us what hub software version and hub you are on?

  • And what devices (brand/model) are they?

  • What driver (device type) are these switches using?

Probably not.

But if these are very old Zwave (NOT the newer plus) they don't report back their status to the hub. It was basically due to a patent that prevented that. So it could be "normal" behavior for these switches. There is a workaround to poll these older devices, and that is what other hubs often do by default. You don't want to do this too much as it is very memory intensive and can cause problems with overuse of polling. Again, if we know the devices, we can advise whether this might be needed.

1 Like

I am running
the switches are GE toggle switch Model: ZW4003
Sorry but I don't know how to find what driver they are running.

These are all z wave plus switches.

Devices tab, go to the setting page for a device. The middle of the page, right side should be a dropdown box with Device Type. That is what you are looking for.

OK, that eliminates one potential issue.

You did it. I had the switch listed as a GE. It needs to be a Jasco. Im guessing Jasco makes them for GE.

thanks for your help


I'd also for giggles (based on your speed comments) check your z-wave status page for ghosts (they won't have routes) If any exist (caused by a failed pairing) remove them.