New setup issues right out of the box - disappointing User Experience

Well, this is my first time setting up a Hubitat, and all I can say is, right off the bat this thing has an absolutley terrible User Experience compared with other products out there.

I'm by no means a novice user, but simply COULD NOT get this thing to function, even after viewing several forum self help solutions (which, non-technical users should really never be faced with in their journey). Apparently I'm not the only person with the same issues getting started with the device. Not very reassuring.

Connecting the hub directly to the router, the light turns green, but then the app simply won't discover it in simple or advanced find mode.

Tried resetting the device, nothing. Tried rebooting the router and resetting the device, nothing.

So I switched to trtying it on a local PC, reset again, rebooted PC... this time I still get nothing on find, but I did notice that 'hubitat.local' seemed to know something was there, but couldn't diplay it (while the light was blue). Once the light turned green, I get 'This page isn’t working
hubitat.local didn’t send any data'.

This seems like a lot of initial screwing around for a device.

1 Like

You're right that it shouldn't be this difficult, and it normally isn't. So, it seems something might be wrong with your hub or perhaps network.

For the easiest path for now, I'd start with a desktop or laptop and leave the Hubitat mobile app out of the picture (it is a completely optional part of the Hubitat experience, unlike some other hubs where it's the only way). Then, try to see if it can be discovered on your network, or use (if you have a C-8) or (if you have a C-7 or older) -- as the card in box should have told you to do -- if you haven't set up anything yet, though technically you don't need to do it that way. If your home router interface has a way to see connected devices, you could also find your hub there by MAC address (bottom of the hub). This will all rule out mDNS issues that using hubitat.local could encounter, though that's normally a good way if you aren't sure.

Regarding the LED, if it's not green, you will likely not be able to connect to your hub via the regular web interface. A green LED means the platform is fully loaded. Anything else and it isn't, though the Diagnostic Tool may still be available.

It sounds like you've already tried ruling out odd issues with your home network (e.g., by connecting it directly to your router), but if you have any unusual configuration like separate vLANs, I'd take those out of the picture for now too. If you configured any network settings on the hub, you could try a network reset and try again.

It is possible, even if rare, that something is wrong with your hub, so if nothing else works, Support can probably get you sorted out. But I'd start with things you can try easily yourself first. These are a few ideas. Good luck!


I find this fascinating. I've bought a lot of Hubitat Hubs over the years and of course I don't have anywhere near this experience. Normally I'd think it is impossible to have it go so wrong.. and thus my fascination at how easy it is really.

The Blue vs Green LED, is one example. I know for example that Blue means it's loading the image and that I can't expect to connect until it's gone green, and even then, you just get the booting % screen. I can 100% see how trying anything while it's Blue would send someone down the "it's not working" path. Fascinating :slight_smile:


Thank you for your feedback. You are absolutely correct that it shouldn't be this difficult to get started. Out of tens of thousands who breeze through the initial set-up, some may run into troubles for various reasons. Many issues we've seen when users are unable to find their hubs on the network, are simply due to local network set-up. Others may run into hardware issues. Based on the details you've shared is difficult to determine which category of unfortunate users you are part of. If you could share more details about your network set-up and the troubleshooting steps you have taken on your own, we could probably help you out with next steps.

How did you try to reset the device? What steps have you taken so far?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.