New issue with Button Controllers on

Hi all,

Since I updated my hubs to version 2.3.6 a few days ago, I'm seeing a new issue with Button Controllers. Put simply, Hubitat stops responding to Button Controller events (such as button pushes) sometime during the night.

My Button Controller Devices are a mix, as follows:
(Z-wave) GE Smart Switch
(Z-wave) ZOOZ Zen32 scene controller
(Z-wave) Hank scene controller

Most of the affected bulbs controlled by these button controllers are on Zigbee, and are a mix of OSRAM/Sylvania "Lightify" (Zigbee) and Ecosmart (Zigbee) adjustable/tunable white LED bulbs. There are a few other Zigbee and Z-wave wall switches that are controlled by the same Button Controller rules.

When the issue manifests, pushing buttons has no effect. Same for double-tap, hold, etc.

I am able to manually turn on/off the Zigbee bulbs (separately, and in groups) and my Alexa integration still works. But the scene controller buttons all stop responding.

I've tried looking in the logs while this happens, and it seems that no events get triggered.

All the Button Controller apps appear to be fine in the web UI. I can go in and click "Run Actions" and things work as expected, but pressing buttons does not work. However, everything returns to normal after I reboot each of the hubs. (I have 4 hubs, one C-7 and three C-5. It's a little annoying). Then it stops the next morning.

This all worked reliably before the update (on 2.3.5).

Any suggestions, other than setting up a nightly reboot rule? :slight_smile:

We would need to see the app that isn't working, and screenshots of the relevant logs, to even have a starting point as to what might be going on.

Hi - I'll try to paste the screenshots here.

Brief timeline: after waking and showering today, I went into the kitchen at 6:14 AM and pressed the button on the ZOOZ Zen32 scene controller that is supposed to turn all the Zigbee bulbs on. They didn't. I poked at for a few seconds, then asked Alexa to do it (which worked). Then I rebooted the hub, and at 6:24 pressed the button that turns all the bulbs off (which worked).

Log of activity in the early morning (for the relevant time window):

The scene controller device doesn't think any buttons were pushed at 6:14 AM.


The Button Controller app in question is here:

Button 5 calls another app to turn all the kitchen lights on:

This is a virtual button controller because I also trigger it from a few other places, so it made sense to define the actions in one place (not several).

I am also seeing issues with Z-Wave Button based devices since moving to I have multiple GE Enbrighten and Zooz Switches (dimmer and toggle) in the house, they connect when I run a Repair on Z-Wave however from there they fail to responded when buttons are pressed in Hubitat. Following this thread for now to see where it lands so as to not muddy the waters here.

I have this issue with different types of z-wave buttons since migrating from a C7 to C8. Still on the latest 2.3.5 version. I can see the led light on the button controller stay lit for a lot longer than on a normal detected pres. On the hub I am not seeing a pressed event. When I reboot the hub or just wait a few hours things will work again.
Cheers Rene