New Hue Bridge Integration in .706

The big news is New Hue Bridge Integration in .706

I don't have one, but I know people have been asking for this for a while, and it's here. Find out what's broke so they can fix it for next patch! XD

1 Like

Not looking good for me so far. It’s not finding my Bridge. :frowning:

Give it time, it can take 5+ minutes to find. Mine takes about 8 minutes.

It’s been 12 minutes now. Still nothing.

If it helps at all I also have problems getting Alexa to discover my devices and I understand that is emulating a hue bridge as well. Correct?

Alexa doesn’t discover your hue bridge? If that is the case, Hubitat will not be able to find it either.

Our Hue Bridge Integration has nothing to do with Alexa finding Hubitat. Two separate processes.

If SSDP / multicast filtering is not working right on your network, you will not be able to discover Hue Bridges and a lot of other devices as well.

What type of networking gear are you using?

Mine took a couple minutes to find. All bulbs found without issue. Does the hubitat integration support “transition” times? I can adjust levels but I don’t seem to be able to adjust the fade rate?

I don’t believe so at this time. The Hue API does have a means to specify a transition time, so it appears we could add it down the road.

transitiontime	uint16	The duration of the transition from the light’s current state to the new state. This is given as a multiple of 100ms and defaults to 4 (400ms). For example, setting transitiontime:10 will make the transition last 1 second.

I’ll pass this on to our integration team.


That would be AWESOME thanks @patrick it is one of the main reasons I use hue bulbs in my home theater room.

1 Like

Alexa does. Alexa doesn't find my hubitat hub either.

I am running an Apple Airport Extreme.

If Alexa discovers your Hue Bridge, Hubitat should as well. Uses same methodology as long as they are on the same LAN / subnet.

I've moved the Hue Bridge to connect to the same switch as HE and still nothing. I've tried connecting both directly to the router, rebooted both Hue Bridge and Hubitat Hub and then attempted discovery again. Still nothing. :frowning:

I just setup Hue on Hue B Smart within smartThings yesterday, and it discovered within 3 minutes, so I know discovery works.

When I get to the step where it asks me to click on the button on the hub to link i get a 404 on the first fresh of the page.

Anyone else having this issue?

1 Like

Just out of curiosity, are you keeping the app open during discovery? The discovery only runs when the app is open in the browser window. If you exit the app, it will start over.

If you get the url on the initial load of the app. The last part is the app ID number.

If you then go to "/installedapp/status/(appID) in a new tab/window you can see the bridges the hub is finding.

The network address is in hex, but if you don’t see anything there, then the hub isn’t discovering anything on the network via SSDP.

Does refreshing the page have it continue as a 404? That seems odd. Just redid my setup and didn’t experience that issue.

What browser / OS?

So far this is working perfectly. But there might be something you should avoid. Needs investigating further. Here’s what happened when I tried the first time.

  1. Added App and followed the wizard (found my bridge in about 10 seconds)
  2. Added my bulbs and then the groups

I didn’t pay close attention to the option below groups, so when it was done, I went back in to look, but didn’t see what I was saw during the initial wizard setup, so I clicked the Hue Bridge in the app and it asked again for the first option to add your bridge again by pressing the button on the bridge. I didn’t do that the second time.

When I tried the lights, nothing worked. I removed all the bulbs and groups, as well as the app. Added everything back, but this time didn’t reopen the Hue Integration app again, just went right to devices and tested my lights. So far, the couple I’ve tested are working fine, including setting level.

So maybe some further investigation might be needed to determine if my app simply needed to be reloaded or if there is a problem, should enter the wizard twice without pressing the button on the bridge, and instead just backing out with the << App list link.

Finally got it! I am rebuilding my network next week because my wife will be out of town. I'll be getting rid of a couple of switches with the new setup so maybe that will resolve some of my problems.

1 Like

Well this turned out to be a great day for me and my Hubitat and a very bad one for my ST hub.
Today I got the last 4 things I needed to retire the Good Ole Boy.

  1. Got my Lifx bulbs transitioned…woohoo
  2. Got my notifications working perfectly with Pushover…taddow
  3. Learned that WOL is now supported…just need to port my ST app for this.
  4. AND the ICING on top…finally…we found Huey

Thank You @patrick and the Hubitat team. You’ve made this a productive weekend for me.


The ONLY thing left keep my ST Hub in service is the ability to control a virtual switch with my harmony hub. I use it to set “lighting scenes” based on active harmony activities. Unfortunately the current harmony hub integrations are based on polling so the delay between the activity becoming active and hubitat registering it is too much for my application.

1 Like

Have you tried using the Harmony Hue discovery to find Hubitat virtual devices and control it that way?

Yeah, luckily for me the delay is a non issue as I only use it for my television and Roku.