New Hubitat user from SmartThings

I am in the process of migrating from Smartthings -> Hubitat. I have excluded 98% of my Zwave devices from Smartthings. I have a detached office, which is where I have (2) Leviton dimmers, (1) MSH200 motion detector, and (1) Honewell Outlet Plug-In.

I'm not following the discussions regarding C-7 and S2, but after excluding my (2) Leviton dimmers, and trying to pair them to Hubitat, the screen is just stuck on "Initializing". Any suggestions, please.

I was able to pair the HSM200. I was also able to pair a Leviton receptacle (which I forgot to mention prior). I have rebooted the Hubitat each pair. Not sure if this is required, but this has been working. The Leviton dimmers still are not pairing.

Welcome to the Hubitat forums!

You may not have to do this, but sometimes it helps. I would also do a few devices, wait an hour or so, and do a few more. That will hopefully help the mesh to settle out a bit between adding devices.

If you have any Zwave (non-plus) devices, you may also want to (or need to) run a repair on those nodes after inclusion.

I am not completely familiar with the Leviton lineup, maybe if you post the model number someone else can give some specific suggestions. But generally speaking, you either aren't getting them reset, or maybe they need an exclude even if you did the exclude with Smartthings. The other possibility is that they want to be paired closer to the hub, or you don't have enough repeaters to allow them to pair in place.

My other suggestion is that you don't want to pair anything with S0 unless you have to. Many of us don't even use S2 or use it sparingly. S0 in particular adds lots of overhead that can slow the system down. The only time you are required to use these security schemes is with locks, garage doors, and a few other security based devices.

Good luck!

Did you try to EXCLUDE the devices with Hubitat first, then try to include them. Also make sure they are on the official compatibility list or you'll need to locate a driver. I came from ST also and I've got about 200 devices and they have all paired and worked much better with Hubitat than with ST.
Once you get the hang of it, it will go easier.
You can also try to disable S2 security features at install if it asks about it. Sometimes this makes things go smoother...


What do you mean by "My other suggestion is that you don't want to pair anything with S0 unless you have to. Many of us don't even use S2 or use it sparingly" ?

Both Leviton dimmers are the same. I don't have the model numbers offhand, but I will try to dig them up. One paired without issue. For whatever reason, one is just stuck. I will try the repair option now.

Devices paired as S0 send multiple events. That basically "clogs up" the mesh for other devices, especially if you pair many things that way, or worse yet if it is a power reporting device where it is already very chatty.

S2 isn't really as bad (theoretically no penalty to use it) but in my opinion, if you don't need it, don't use it.

What I was trying to ask: how do I do one vs. the other? Or disable one vs the other? Although I have a ton of Zwave devices, I've never heard of S0/S2 prior. I suspect Smartthings abstracted this detail?


Upon including, there could be a couple things that happen. You might need to push a button once, for example to pair unsecure, and multiple button presses to pair secure. On the newer stuff, it asks when you do the inclusion if you want to use XYZ security levels.

The only way to change security levels is to exclude and include the device again, there is no mechanism to change things in place.

You can go to Settings tab, Zwave Details, and in that table it will show how a device is paired.

Thanks. I have always pressed the button once, so this is good to know. I have the hub 8 feet away from switch. At this point, nothing has worked. Not sure what I could share that would help. The device stays in init after: reboot, exclude, reboot, wait 5 mins, try to include. Suggestions?

Also after every failed pairing, check for ghosts. If one exists, delete it before attempting to pair anything again.

That is specific to some particular device. It might be 2 presses, 3 presses, or whatever.


If any Zwave device is missing both in cluster, and out cluster info, it is a ghost.

If you take off the wallplate, the device number for the Leviton should either start with DZ or ZW,

If you have the DZ, they are ZWave Plus but do not have security.
If you have the ZW, they have S2 security.

You can also reset them by pressing and holding the ON button for 14+seconds until the Indicator light blinks Amber/Red. This will automatically unenroll the device on the device side. The device will send a Device Reset Locally Done to the Hub and that should make the Hub unenroll the device from the hub.