New Homebridge Plug-in via MakerAPI

Are you saying that it gets out of sync after a Hub reboot and you didn’t reboot Homebridge? And after you reboot Homebridge everything is fine?

No, I meant to say that as a workaround when it gets out of sync I tried those reboots but it really didnt help other than restarting Homebridge (or rebooting the mac mini which does the same thing). I rarely reboot my hub as I havent had a need to (other than hub updates).

I am currently running hub version:

Which node version are you on?

Not sure whom you're asking, but I'm on Node 8.11.3

I was asking @walksonair but it is good to have your reference too. I am on 8.14.1

1 Like

node --version


I recently updated to see if an update would make the sync issue go away...but it didnt help.

What version were you running prior? I've always run 8.11.3 because I need it for compatibility with Google Assistant Relay which has problems with later versions.

I am in same version. Same issues and on latest HE updates.

After rebooting the RPi I am back in sync. But this started all between H HH E update and Apple updates. So not sure what is causing What issues.

I dont remember but I dont think it was 8.xx...most likely higher.

For security and other reasons, I update the NPM and Node on a regular basis....which is part of an update script that also updates Homebridge and your Hubitat-hombreidge plug-in...

What I can do right now for you is run Homebridge in debug (DEBUG=* homebridge -D) and give you any output via DM...

Do you have a spare SD card? Maybe clone your card and try an experiment with downgrading to 8.11.3 or 8.14.1 like Dan is running. But do clone your card. Don't want you to accidentally mess up your Homebridge install. I know what a pain it can be to get Apple's fragile home automation platform setup right.

Highly recommend the Controller Pro app to backup your HomeKit devices and automations if you're not already using it.

1 Like

Dan is the man when it comes to the Debug output. I'm just a Homebridge MakerAPI cheerleader because it works so well for me.

1 Like

I am going to update my node installation and see if I can replicate the issue. Being able to replicate is the one thing I need to fix it or ask the Homebridge developer to fix it depending on where the problem lies.

One more question, what operating system are you on?

Mac OS 10.14.6

Thanks, Dan, for taking care of us!

**I should add that the sync loss is only after a while...not sure how long...maybe an hour or two but it's noticeable throughout the day (and night).

1 Like

Just as feedback, just upgraded my node version to 12.10.0 and let's see if I get the same issue by tonight. I'll be away from my computer for the rest of the day but hopefully see something later in the day

Well, for what it's worth I havent seen any sync issues since I put homebridge running in its own terminal with the debug command....

I had to restart my mac mini and it is now running as before through a launchd plist file for Homebridge as specified in this guide: Install Homebridge on macOS · nfarina/homebridge Wiki · GitHub

I will keep an eye out though and report when I do...

Might be related. I don't run mine via launchd. I manually start all my node.js applications in terminal windows

I needed a way for Homebridge to run when my comp restarts or starts from power failures...

I run on a MacBook Pro, but don’t allow it to restart itself. It’s on a UPS, so brief power failure will not effect it

My AppleTV was a couple beta versions behind for some odd reason. After updates I haven’t seen sync issues. Going on 5 hours currently.

1 Like

I use pm2 to start my Homebridge instances on boot. No issues with that either. So far I don’t have any problems with 12.10.0, but I’ll keep it running