New Homebridge Plug-in via MakerAPI and Eventsocket


#41

Debug logging for Homebride? I usually only use that when I am trying to troubleshoot something?


#42

Just a quick update...things have been running great so far with version 0.1.2. Totally stable with no slow downs whatsoever. If you were on the fence with trying this its a great time to jump right in. Thanks again for your work this @dan.t ...I've been following your changes in Github and can't wait to try out your next version when its ready.


#43

Concur on stability this week - can't wait for the updates!

Is there currently a functionality to remove capabilities like tonesto's does? My window shades show up twice, once as shade and once as a switch/dimmer...


#44

I believe Dan is woking on this for the next release.


#45

Yes, as @tsviper said, it is coming in the next release. Hopefully next week, just doing some stability testing.


#46

The hardest part of this was the Raspberry Pi setup... once that was done, this app is phenomenal! Thank you! This is the first user app that I have installed that has been rock solid and functioning extremely well (knocking on wood). Thank you again!


#47

So if you’re looking into the ability to exclude capabilities also look into the capability to exclude an entire device. The reason being is I expose several devices through maker api and don’t necessarily want them to show up in HomeKit because they have nothing to do with HomeKit.


#48

See posts 16 and 17 above.


#49

Yes it references capabilities. I’m saying exclude devices that you use for other reasons on maker api and don’t need for HomeKit.


#50

@JDogg016 The best way to seperate it is by having another MakerAPI instance installed. I actually have 5 MakerAPIs installed right now. You can install as many as you want. This way you only expose the devices that you want to be exposed for each purpose


#51

My mistake, posts 17 and 18. They discuss exactly that.


#52

@dan.t this is working out quite well overall. One thing I noticed is that your plugin does not know the state of the devices if either HE or the RPi is rebooted. Tends to get into a funk to maintain state.

The two issues I am experiencing:

  1. Switches still activate in Home app on iOS but they immediately turn off for the indicator. Almost like they are a momentary switch. The lights don’t go off but do what they are supposed to do.
  2. Siri doesn’t work at all for voice integration. States I need to open the app. Is this a Homebridge issue where I need to delete the persist directory and setup again?

#53

Hey @aaron, both of them sound related to a refresh issue that occurred after an hour of the plugin running...
do another npm -g install homebridge-hubitat-makerapi to make sure that you have the latest version installed and try it again please.


#54

The update fixed the sync. Still have Siri issues finding anything in Home. :frowning: Keep getting the response "Sorry Aaron, I wasn't able to find anything like that this time."

When you open the home app everything appears from homebridge and is actionable. Thoughts?


#55

uh oh, just updated to the latest maker-api plugin published 15mins ago and am not able to start Homebridge anymore. I reverted to v0.1.2.

This is the error I see on my terminal when I try to run HB w/ latest:

/usr/local/Cellar/node/11.14.0_1/lib/node_modules/homebridge-hubitat-makerapi/accessories/he_st_accessories.js:46
    that.accessory.getService(Service.AccessoryInformation).setCharacteristic(Characteristic.SerialNumber, group+':'+device.deviceid);
                   ^

TypeError: Cannot read property 'getService' of undefined
    at new HE_ST_Accessory (/usr/local/Cellar/node/11.14.0_1/lib/node_modules/homebridge-hubitat-makerapi/accessories/he_st_accessories.js:46:20)
    at populateDevices (/usr/local/Cellar/node/11.14.0_1/lib/node_modules/homebridge-hubitat-makerapi/index.js:72:41)
    at /usr/local/Cellar/node/11.14.0_1/lib/node_modules/homebridge-hubitat-makerapi/index.js:113:17
    at /usr/local/Cellar/node/11.14.0_1/lib/node_modules/homebridge-hubitat-makerapi/lib/he_maker_api.js:130:21
    at IncomingMessage.<anonymous> (/usr/local/Cellar/node/11.14.0_1/lib/node_modules/homebridge-hubitat-makerapi/lib/he_maker_api.js:88:17)
    at IncomingMessage.emit (events.js:198:15)
    at endReadableNT (_stream_readable.js:1139:12)
    at processTicksAndRejections (internal/process/task_queues.js:81:17)

#56

Sorry about that @walksonair . Just fixed that. Updated again please.

Tried to do something “quickly” to prepare for the next bigger release that is coming and I guess I did it too quickly. Amazing how quickly a one liner change can bite you in the ....


#57

Hmmm, not directly, I am at an airport in Ireland and don't just want to send commands to my wife at home. I double check later today biut I use voice commands all the time....


#58

Ok, HB booted up and looks to be working w/ 0.1.4 Thank you!


#59

I am just googling and found this: Siri not finding any devices all of a sudden. Home app works fine and so does Siri on Apple TV. Why’s is it not working from my phone? : HomeKit

They say to turn off Siri, wait 10 minutes and turn it back on and it worked for them. I don’t think that your issue has anything to do with Homebridge


#60

All of the iPhones in the home have this issue now. :confused: