New C8 unit dead?

I received and set up a new C8 yesterday but today I think it is dead. I noticed an automation had not run, and when I went to access the UI, there was no response. At that time, the unit was powered with the provided brick and cable, connected to a TP-link switch via the provided rj45 cable, and displayed a green light.

The DHCP leases showed the hub as offline. I had assigned it a static IP in pfsense.

I tried different cat 5 and 6 cables, and no cable in an attempt to discover the hub but no change. (during this time I had not yet unplugged it and the light was still green)

I then removed and after 30 seconds reapplied power. From this point on the unit will not power on (no LED light of any color). I tried different USB cables, and power bricks + a wall outlet with USB connector.

Ive held the reset button for 7 ... 10 ... 30 seconds but still no change.

Is there anything i'm missing? Just a bum unit?

It could be - I can't think of any of the "normal" issues that would cause what you have experienced.

You can start a claim at Warranty – Hubitat Support
That will also get the attention of support for your issue.


No LED typically means no power (or dead). Submit a warranty claim.


Thanks. Submiting a clam.