New C7 hangs updating firmware from to

New to Hubitat and home automation as well. I'm off to a very slow start. I've recently purchased a C7 hub from The Smartest House along with some of their switches and sensors. The first thing I'm trying to do is get the hub up and running. The installed firmware is clearly out of date so I figured I would upgrade it before doing anything else. After 3 days of reading here and trying various suggestions I'm still stuck at step 0.

I can boot the hub with the installed firmware release of However, the upgrade process of installing release always hangs at the screen "Your hub is starting up. Please wait..." with "Initializing Hub: 25%" with the hub LED being blue.

Using the Diagnostic Tool I have tried to "Reboot Hub", "Shutdown Hub", and even "Soft Reset". No luck. I've tried physically power cycling the hub. No Luck. I can revert back to the installed release and get it to boot with the hub LED going green.

I have not tried the "Full Reset" option but I'm starting to consider it.

Has anybody attempted a firmware upgrade from release to release Does anybody have any suggestions on things I can try?

I cannot ping your hub from the support tool, but please give 2.2.7 a shot. I can check what's happening once the hub is online and accessible.

Don't do a full reset.


I don't follow how you would be able to ping a hub on my network from outside my network.

In the process of updating to 2.2.7 I get:

Corrupt database found
Hub cannot continue. Please try the following actions:

Reboot the hub. Sometimes, a database file is locked but otherwise intact.
If that doesn't help, the hub needs a soft reset and a database restore. Click here to access diagnostics tool.

Rebooting and Soft Reset both result in the same Corrupt database found error. It's not clear if or how I can do a database restore in this state.

It's a more informative failure than updating to 2.2.6 but I appear to still be stuck. There's really not much in whatever database there might be and what little might be there isn't of any importance.

It's not ping in a network tool ping sense, but there's a limited MQTT-based communication channel between hub and support tool.

So, a soft reset does not clear database error? It should restart the hub and show a green "getting started" page.

It turns out "Hub cannot continue." isn't the same as being stuck. I see that I can click "Settings" and initiate a database restore. I am attempting that process now.

1 Like

I can't get past the corrupt database stage. I've tried rolling back to different databases including one that had a 2015 date. No luck. I've tried reverting back to and updating again using various datebase saves. No luck. I've tried saving a database to my PC and restoring from that using both and 2.2.7. No luck.

At this point I'm still spinning my wheels.

I've reverted back to and will leave it there. Perhaps some one can use the limited MQTT-based communication channel to poke around the hub as I'm at a loss what to try next.

Could you please try switching to version 2.2.7 and doing soft reset while it is the current version, even if it complaining about corrupt database? That should bring up the getting started screen on hub reboot.

1 Like

I have switched to version 2.2.7 and did the soft reset using the diagnostic tool. This is the screen I get by going to the hub.

I then rebooted the hub using the link and still get the same page.

While in 2.2.7, could you please go to endpoint?
Replace with the actual IP.
So far, it's acting like soft reset doesn't actually delete the database.

1 Like

success, attempting to reboot hub now

Your hub is starting up. Please wait...

And then the green "Getting Started" screen.

Thanks for your patience and help getting me this far. I have some concerns about how hard this was and that some basic functionality is not working.

Again, thanks a ton.

I will give it a go from here and maybe install my first wall switch.