New C-7 Hub connection problems, can't connect by App, my,hubitat but can by IP in address bar

I bought a new C-7 hub so I could extend my range to my barn 250 ft away from my C-8 which replaced an old C-5. I chose a C-7 so I could use my old Iris V1 devices and also take advantage of the range of new Z-wave. Initially I had a problem with the C-7 connecting in the barn. The blue LED would not change to green. I contacted support but after days I noticed the light had turned green. I was able to add devices, set up dashboards, and connect to the hub by my.hubitat, the App as well as directly by the IP. Then a progressive loss of functionality/connectivity occurred. First remote access was lost. The app still worked locally but then could not download the update. Diagnosis via 8081 told me the MAC I entered was incorrect. Triple checks and new entries produced the same message. Then the app gave the message that it could not connect and gave me a link to support. The link gave instructions for a factory restore but it stopped working at 65%. I read posts about blue light blues but nothing I found helped. I brought the C-7 to the house from the barn and connected it next to the C-8. The blue LED turned green, it seemed to function normally, but its return to the barn indicated all was not well. The app and my.hubitat on my PC could not connect locally or via remote access but they worked fine with my C-8 in the house and also my old C-5 a mile away at a family members house via remote access. So the problem did not seem to be my internet. When I typed the C-7 IP number in my PC address bar in the barn, it connected immediately to the C-7 and the menus I tried worked. But the local access in the Hubitat app (Connect To) would not work. I have contacted Hubitat Support but have found they are not quick to assist. I don't know if the hub has hardware problems or if there are some settings that need changed or something else. Help would be greatly appreciated.

It sounds like you are having internet connectivity issues with your hub when it is in the barn.

Could you describe how your hub is connected when it in the barn? Wifi? Wired? Separate network?

I wouldn't put much stock into the Hubitat.local not not working, it appears some are having issues with that for some unknown reason. Many of us only use the IP address, and bookmark that. You hopefully set an IP address reservation in your router so that your hub is always in the same IP address.

Did you fill out the form in the support portal? Did you receive an automated response?

It typically takes a couple hours to maybe a day in rare situations to receive a reply, but it is often fairly quick. If you didn't get an automated response, something probably didn't work right. We can tag support if you don't hear something from them.

When I submitted the first form about the blue LED it was 11 days until I received a response. It's been over a day for the 2nd request.

Thank you for your response! The C-7 hub is connected by ethernet to the router in the barn. A cat6 cable runs underground from the modem/router in the house to the barn. Perhaps I should see what happens if I switch locations with the C-7 and C-8 hubs?

Local had worked until the last update.

You have two routers in series with each other? Barn router :arrow_right: house router :arrow_right: modem?

I am not the networking expert, but that probably is why you are having issues.

Thank you for your information. The configuration is correct as you show it. I am certainly not a network expert either. From the info I found, this is the most common way, and some sources said preferred way, to extend the internet to an outbuilding. The routers must not have the same gateway ip or there would be problems but that is all I found regarding conflicts. The IP for the hubs are different for the last 2 sequences of numbers ( and xxx,xxx,0.x. The suggestion I received was to give the 2nd router the same name and password so my cell phone would switch automatically. I hope I will hear from a network expert. Thanks again.

You could use a switch in the out building instead of a router ,,
that way the house router will do the ip routing and everything will be on the same lan.
you then can have the barn router and hub connected to the switch.
I am guessing you need the barn router for wifi.
if not then you would not need the other router at all.
this may work better for you. or do what ogiewon said :slight_smile:

1 Like

It sounds like the issue is caused by "Double NAT" (i.e. daisy chaining two routers together) in your network configuration. What Brand/Model is the router in the outbuilding? Hopefully, you can reconfigure it for "Access Point Mode" instead of "Router Mode". Most modern routers can be put into AP mode, which allows them to simply be an extension of your existing home network without creating a new network of their own.

In general, you'll want the Main House Router to be the only DHCP server on the entire home network. This will allow all devices, in the house and in the outbuilding, to use the same network address VLAN. This will greatly simplify the network and allow devices in the outbuilding to behave the same as those in the main house.

1 Like

I really appreciate your comment. I will check on AP mode. The current router in the barn is an old Arris Surfboard SBR-AC1750. My son has loaned me a Asus RT-AX1800S to try. If a new modem is needed, do you have any recommendations? I will also probably try a switch as WarlockWarrier suggested.

Thank you Warlock. I'll get a switch to try. Wifi in barn would be nice but not essential.

1 Like

any 5 port cheap switch will work ..
You need a Unmanaged Ethernet Switch
like this one :
Since no wifi .. really you could just plugin the HUB into that cable coming from the house.
No switch needed :slight_smile:

No reason to restrict yourself to Ethernet connections only, if you want WiFi in your barn.

I don’t know off-hand if your old Arris router can be configured to run in access point mode, but if you google the model # there should be a user manual available online somewhere that can clarify that.

The ASUS router can definitely be put into access point mode.

I just looked through the manual for the old Arris Router. No obvious "Access Point Mode" that I could find. Could probably configure it manually to do so, but it would be better to simply use a different device that properly supports AP mode.

Agreed! The Asus routers are trivial to configure as dedicated Access Points. This is the simplest solution, by far!

1 Like

Try this

Turn Off DHCP

1 Like

That looks like a good start.

But I’m guessing the “NAT Mode” setting that’s also visible in the screenshot of the router settings page (just below DHCP server settings) would need to be changed too.

If it has an option for “bridged” mode or something to that effect, then it would probably work ok for this purpose.

From the forum posts I was reading, there is no AP or Bridged mode as named. And yes, i would think the NAT would need to be changed if it is not automatically disabled when you uncheck DHCP.

1 Like

Thanks for the additional information. I connected the C-7 directly to the ethernet in the barn and it is working much better. I also order the TP-Link TL-SG105 you suggested from Amazon and received it already, I will also explore using the Asus router in AP mode. I've learned a lot. Appreciate your help! Now I need to figure out why hubmesh is not working.

1 Like

Thank you, I agree Wifi will be nice for computer running my CNC in barn and I'd like to add a Wifi camera also. I'll explore AP mode with the Asus.

1 Like

If you simply make the SSID the same as everywhere else then backhaul it from another router to the switch portion of the router and don't plug anything in the WAN port that will be just fine as an AP. Make sure you disable DHCP in that one.

1 Like