New 2.2.5 Z-wave bug

Just restarted my hub and "lost" a Z-Wave device from "Z-Wave Details" screen.
The screen shows 21 devices however I have 22 showing in Z-Wave topology and the orphaned device is still accessible and functions normally in the devices screen.
Currently running and device still missing from the Z-Wave details screen after running a full z-wave repair.

(node 11)

yet missing here...

What's interesting is that it still appears in the z,wave logs and appears to function normally.

EDIT correction... can't count. It also missing from the topology screen. LOL

@gopher.ny is this something that is being looked at?

Have you tried the standard, safely power down the hub from the menu, remove power for 30 seconds+, and power it back up? This is likely something specific to our hub and zwave network. Donโ€™t think Iโ€™ve seen widespread complaints about this specific issue.

This would also be more of a @bcopeland thing.

1 Like

If you reboot.. Does it show back up?

No still missing. I have intentionally left it alone and not deleted and re-added in case it is of value to find root cause. I have also just upgraded to and still not there.

1 Like

Not sure if everyone would notice especially if they had a lot of Z-wave devices. I don't have too many z-wave devices on here yet (most still on ST) and even I didn't see it until I happened to be looking for it here.

What type of device is this?
When you say it is "appears to function normally", do mean that you are able both to control it from HE and see reports/events from the device in HE device events?

It's a Greenwave Z-Wave outlet. I can control it normally in HE from the devices screen and apps and it's actions are reflected in the Z-Wave logs. The only thing that is missing is it appearing in the Z-Wave details and topology screens. It was there before but suddenly disappeared after a reboot in a recent firmware update.

Iโ€™ve actually experienced this same symptom in the past. I had a number of Leviton VRI-06 (and similar) devices just disappear from my network. I figured they must not have sent anything out in a certain amount of time, and the hub scrubbed them or something, believing they were ghosts or something similar. I could still interact with them on the network (except for one time), and device associations still worked.

That was back in July, I think I had about one of these per month, and I blamed the database corrupting, or the aforementioned ghost device hypothesis.

1 Like

It is indeed a device I don't often use so your theory could be right. If there's little interest in closing off this bug from the platform owners, I'll simply delete and re-add it back. No biggie.

If HE staff aren't going to pursue this, it would be interesting to see if doing a download and then immediate restore of the hub database affected this.

That or a download, soft reset, upload.

Interesting thought about this one. The fact that it's it's working, it's clearly part of the mesh. However, it no longer appears in any of the routes or neighbours in the Z-Wave details page or leven listed in the topology page. It used to be a very active repeater as it is located right next to the hub. Could node 11 actually be actively repeating but due to the fact that the interface has omitted it, it simply does not list it doing so anymore?

The hub gets this list from the SDK to display in the Z-Wave Details page.. I suspect this is another example of why they changed the underlying database in the controller SDK. 2.2.6 will be getting an update to the SDK.


Does the old database get converted automatically to the new database form upon install?


1 Like

@bcopeland spoke too soon. Looks like my hub has had a complete Z-Wave meltdown. Nothing on Z-Wave radio responding at all for last hour and a powerdown of 30 seconds and reboot has not recovered the system.
Took a very long time to boot up and everything on Z-Wave looks like this:


tagging @gopher.ny if you can help advise what I can do to recover my system

Can you PM me your hub id so I can pull the error logs?