Never ending "firmware update for null failed" messages

They don't stop.
How do I shut them off?

It seems to happening every 10 minutes, in groups of 3.

Try a reboot of the hub.

1 Like

I tried a shutdown and power cycle before I left the house, (just got back and going out again).
Presence sensors (zigbee) aren't working, not sure if anything else yet.
10 minute attempts. I know the Hue does 10 minute updates of lux, but there's no clue about which device is failing to get its firmware updated.
Is there anyway to trace this?

@support_team might be able to look at the engineering logs, outside of that maybe try turningoff the radios for a couple of minutes.

I just turned on zigbee logging and disabled a Hue motion that had activity right before the warning, but I think that's just a coincidence.
You'd think the warning would have more info on the device that failed.

I had the same issue...

Finally, I just gave up and stopped looking at these messages (I archive my logs in a database).


I think it could be causing some problems though. I'm not just letting it slide.

Sometimes it's every 20 minutes.

I'm not sure the zigbee log is showing me anything.

I've got to leave the house again. I'll hang around fooling around with this thing when I get back.

I have a gut feeling this could be a Hue thing.
I might have tried a firmware update on a Centralite 4200C plug, but forgot what else I did last night/early morning getting my zigbee mesh back up.
The error seems like when I tried to update the Hue motion firmware with the native driver, as opposed to the Smart Button work around.
Now it's been over a half hour without a warning since I disabled the Hue Motion Sensor I mentioned above. Maybe I'm onto something. Have to leave now. Will check when I get back.

Disabling that didn't help.

Zigbee Log:


The times are pretty close.

Here's the latest:

Zigbee Log:


Device 125 seems to be involved.
Device 125 is "MBed Zig Plug"

Well, how about that, it's not responsive to device page commands!

I started down the reboot zigbee radio last night, and it lasted into the wee hours because another Centralite 4200C zig plug behaved the same way. Turned out, all I had to do was unplug and replug the outlet. Why don't I wander upstairs now and see if that frees things up. Stay tuned...

Well, how about that, working like it should; instant response. The other recalcitrant plug I mentioned earlier is still working snappily since 2 AM or so this morning. All with no rebooting or rebuilding of zigbee radio.

Now it remains to be seen if the warnings are still being cranked out. At a nominal 10 minute interval, it should take too long. Maybe a half hour would be conclusive. Maybe an hour? Stay tuned...

1 Like

I think it is more than those Hue. I don't have any Hue, and I have been intermittently getting these messages. And I have not touched the firmware update button at all in months if ever. I think it is some bug that the error is either just false, or for something different than what the error actually says.

The one set of these errors I did solve by replacing a low battery in a device. I would think about all battery devices and if there is something that you haven't replaced recently, it might help to replace it before digging into this error any deeper.

I might be on track.
I haven't had a warning for an hour.
I'm hoping it was the zigbee plug, not the Hue.
Although, replacing a battery in a device is kind of like unplugging/replugging an outlet.

1 Like

The time is nor 9:36 PM.
More than an hour since the last warning.
Too early to declare victory?
If still good by morning, I'll check my own solution box.
Although, it's not really a solution, is it?

Well, I just woke up on the sofa at 2:07 AM and still no hub warnings.
At great risk of jinxing it, I'm declaring success. :slight_smile: