Network is unreachable error

Recently my Sharptools app has been having issues sending commands through to the Sharptools server. I don't know when this started as it is very difficult to look at historical logs (if anyone has any suggestions on this I would love to hear them).

I have tried all the usual things, checking the network, checking the hub, reinstalling the app. I can ping the destination fine from the hub. I am working with Sharptools support - there is nothing wrong on their end or we would be hearing from a lot of other hubitat users. I have opened a request to Hubitat support. I did not find any other references to this type of error message in the forums.

It is not happening all of the time - I would guess that about 1 in 20 times. And I have not been able to pin it down to one specific device or device type update so for right now I am assuming it is random.

So I thought I would post here to see if anyone has any thoughts. Thanks.

Here is the error message:
Error sending event to Connect to [,] failed: Network is unreachable (connect failed)

Tagging @josh

1 Like

@aaiyar Thanks, I have been working with @josh - here is the link to the diagnostic work so far on the Sharptools forum:


The error message is interesting: Network is unreachable (connect failed)

I would expect a different network error for platform issues - for example, if I take my local development instance completely offline, the error is "connect timed out". Or if there was a server-side error, I would expect it to be reported, eg. "status code: 500, reason phrase: Internal Server Error".

The only other mention of "Network is unreachable" I found in the HE community referred to a network configuration issue (router)... but it also seemed to always impact that integration (eg. it wasn't intermittent but recurring). And more broadly, search results for other software seem to indicate that it's commonly a more fundamental network issue.

Just seems odd that it's happening intermittently, seemingly started recently, and there's no known hub/software/network changes.

@josh Definitely no new apps. I have only uninstalled apps as I was cleaning things up.

Perhaps ran the hub update most recently. I haven’t found a way to go back in time on Hubitat logs to see when it started. As an aside I am going to connect my hub to my syslog server so I have that visibility in the future.

I did create a lot of new rules that I use for updating sharptools on audio system status. Perhaps about 50 - 4x12 zones. All these are doing is switching devices on and off based on zone status, Source etc.

Quick update - issue has now gone. Not sure why, or why it was throwing the errors in the first place. So keeping the support ticket open just in case.


@simon4 did you ever get to the root of this problem? I'm having the same problem. Mine spans multiple cloud-based apps, though, not just sharptools - so it's widespread. Any insight you gained from your experience would be appreciated!

Did you set a static IP on the hub, or are you using DHCP? Did you set an address reservation in your router? Which hub model is this?

Using DHCP with address reservation in my router (has worked for years). This is C5

Tried pinging those app servers via the network testing on the hub?

Is is possible your router updated and has changed settings or is blocking Hubitat somehow?

Yes, the tests work just fine.

Not that I'm aware of. The calls go through sometimes, but not others, so that suggests to me that it's not a blocking issue. Right?

I am far from a networking expert. But I have seen my router think that the Hubitat was "spammy" and block connections for a period of time. I can't remember exactly what/where it was in my router, I got a new router a while back and the options are different. I think it was under DDOS protections though.

Maybe list your router brand/model and see if someone knows something about that particular device.

1 Like

Netgear Orbi RBR50 with latest firmware (V2.7.5.).

@JustinL Yikes, I had forgotten all about that nightmare. I haven't seen it in a while, and I have no idea what eventually fixed the issue. As you can see from the thread, Josh was very supportive but from what I recall, on the Hubitat side I got nothing back. I have changed so much in my setup since then but I don't think this had anything to do with it as the issue came and went without any changes. I wish I could offer more insights as I know this is incredibly frustrating.

1 Like