Netgear Router Issues

Well, I thought that the firmware upgrade to my Netgear Nighthawk RAX40 router would be okay. That is, until today when my computer went down. When I brought it back up, I could not reach either hub. I was trying all sorts of things unsuccessfully. Finally, I downgraded the router's firmware to the last one I was able to use successfully, which is the V1.0.3.64 firmware. It restored my ability to see the hubs again.

What is up with Netgear? I'm about to go out and look for a different brand. Which ones are people using that have not had these issues?

I'd guess that the firmware upgrade may be okay, but that there is a setting that gets changed or added that may need to be set differently. Any release notes to say what they're changing.

The problem is that I don't see anything in the notes to indicate what changed that would cause the issue. I don't see any settings that are different after the "upgrade." That's what makes it so puzzling and frustrating.

Edit: The problem seems to pop up in the wired LAN connection. I can use my netbook, connecting to the router via WiFi, and I can see the hubs just fine. However, on the main machine which is connected though a cable, I can't. The hubs are connected to the hub through cables also.

Anyway, I am about fed up with Netgear.

I had 4 different Netgear routers, the last being an AX8. They were all terrible; AirPrint only worked for about 5 minutes after a fresh reboot of the router and none of them seemed to be able to handle gigabit internet. It would rapidly drop to 500mb/s after a fresh reboot. I ended up returning the last one (the AX8) and buying a Lynksys Velop MX5300. It has been flawless. I never have to reboot it to maintain gigabit speeds. Even the printer works perfectly, and we all know they’re not supposed to. It has worked so well, that I bought another for my son’s room (hardwired ethernet connection) which was the only weak area. It was on sale at Costco for $199.

I had a VELOP and over time there were a lot of incompatibility issues reported, especially with Ecobee, which I have, even after assigning the Ecobees static addresses. VELOP has some fatal errors in firmware updates and I switched to Netgear Nighthawk mesh and have not had a problem since.

What is the IP of the machine that can’t connect vs one of the hubs? Might be using a different subnet. Another possibility is that the one machine may not be set to see the rest of the network.

Well..I have had the first Velop for almost a year now with no issues. It usually has around 50 devices connected (4 kids). Including a Nest thermostat, HP laser printer, Wyze cameras, a TP-link outlet, a Samsung Oven, and a bunch of idevices. Did you have the MX5 (5300)?

Honestly years ago I got tired of wifi routers. Even with tomato on them they sucked.... Maybe they've improved but for my home use I use a Watchguard T-35 (a t-15 is more than good enough for home gigabit use but I have a couple of other needs bandwidth wise). Coupled with several Unifi AP-AC Pro's, I honestly never have problems.

That’s been my experience as well…until my current setup. I’ve probably had more than 10 different routers from TP-link, Asus, and Netgear over past 20 years and this is the first time I’ve had one that didn’t have some issue I hoped a firmware update would fix.

No, I had the AC2200, 3 nodes. System was solid except for Ecobee problems. My HVAC has gas aux heat and Ecobee gets the outside temp via WiFi, so a necessity for me. When it became a widespread problem that Linksys could not/did not fix, I moved to Netgear.

1 Like

They are all 192.168.1.x addresses. It works. I do the "update" and then it doesn't work. I revert to the old firmware, and everything works again.

I tried addressing this on Netgear's community forum and the only answer I got is that Netgear won't help because it is past their "free" support date. I could purchase a support package to try to get this addressed. However, Netgear took something that worked and broke it. I think Netgear should fix it.

Don't disagree that they should either fix it or tell you what setting they changed, just try to figure out what they may have done. Odd that only one system, and the one that is using a wired connection, is affected.

You are too kind. I had been a Linksys customer since they introduced their very first Wifi router. Velop was the end (AC2200 series for those who are curious). Every single firmware upgrade left me on the phone with support for HOURS. Even when it wasn't in meltdown I had all sorts of issues with nodes dropping off, not being able to connect to a node sitting next to me, compatibility issues, etc. I came back from vacation one day and my entire network was down. Surprise, surprise - they had pushed an update while I was gone. When I called support they said my nodes were too far apart. Yup, that's what happened - nothing to do with your crappy firmware update. Rather my house was replaced by a TARDIS while I was sailing in Belize.

After that experience, I disabled auto-updates and just let it run, but I still had tons of problems and when I called support their first answer was "well, you need to update your firmware." I don't know if it was the hardware or their development process or both but I will never, ever, ever buy a Linksys product again. Or WeMo for that matter.

I ripped all that stuff out last September and went with Unifi - a life-changing event. My RTL from my house to our MSP data center went from 150ms to 37ms. Packet loss dropped to zero. No outages, every firmware update has been a breeze (though I do not do automatic updates), Our game room doesn't go offline periodically, my ecobee stays connected, and the whole thing is a ton more secure.

Lessons learned from my adventure:

(1) stay away from consumer-grade stuff
(2) hard wire where possible
(3) no non-managed devices
(4) wireless backhaul is a compromise I'm not willing to make

**drops mic

OK, but for those of us who don't want to learn some sophisticated networking concepts or language, is buying some Ubiquiti hardware just plug and play? The value of the consumer grade stuff to me is that you buy it, plug it in, complete the setup screen and just use it. Over the years, many, I have found Netgear to be reliable. I had switched to Linksys because they had the mesh network first, but you know what the say about catching spears at the front of the pack. I had to switch to Ecobee from Nest because Nest lied about dual fuel compatibility in their first version. So yes, I have made some mistakes, but my Nighthawk mesh has been set and forget...so far.

Good point. I would not describe Unifi as plug-and-play, though there are less complex Unifi installations that may be closer to that experience.

And that's a convenience not to be dismissed.

1 Like

Plug and play is how my Linksys setup has been. I can’t speak for any other Lynksys products, and I know the price of these is a little steep for consumer mesh WiFi, but for my sanity it’s been well worth it.

The Ubiquiti Amplifi line is good. I used it for a while then I rebuilt my network around Unifi. There are some limitations in the Amplifi. For example you can only have one subnet and I had exceeded 255 devices so I moved on but I highly recommend Amplifi. It also has VPN capability builtin from iOS devices from outside of your network.

In fairness I should also point out that consumer-grade gear is a LOT cheaper. With commercial-grade hardware comes commercial-grade pricing.

I did not look, but the last time I tried an update, it also appeared that the hubs could not talk to each other either. That was when I was using Hub Link/Link to Hub. I'm using Hub Mesh now. I did not check whether that was still working. I was too busy trying to get this computer (Linux Fedora 35 and Brave Browser) which was working just fine before the update to be able to recognize that the hubs were there.

One more thing to add to the mix. It did seem to be working initially after the update. I had someone send an mp4 file that when VLC tried to play it, the computer rebooted instead. I'm not sure what was up with that. It was after the reboot when I tried to get my browser setup for the dashboards again that I noticed the problem. Again, after downgrading to the old firmware, it started working again with no changes to the computer. So, the solution seems to be to just ignore the "updates" and keep it on the working firmware.

1 Like

Download the Hubitat app