Needed help with a Tesla power wall

Probably one or more dumb questions. I'm trying to get my Powerwall2 connected to my Hub, I have played a built with this and Darwin's Power Wall manager app (which I think at least in part uses some of this app), but I keep getting hung up on authentication. Specifically which password do I use? I tried the same password I use to log in to the tesla app, and it says that's no good (but I can log into the app just fine with it). I have put in the IP address I have in my router for the power wall, it says it can ping it, but that the password is wrong. (That may be from Derwin's app) I just can't seem to figure out how to get this brought into my hubitat, can anyone help me figure this out? I have no issue going with this app, IF i can get it to work. Generally, what I'm looking to be able to do is set up an automation so that if we lose grid power, then kickoff (or at least change the temp settings on) my HVAC in order to maximize the amount of time we have power to the rest of the house. Can anyone help here?

Have you tried the password that is used to log into the Powerwall? It's normally the last 5 characters of the Powerwall wifi password (at least that was it in my case).

1 Like

yep. I have tried both the password I use for the app and the password on the sticker on the power wall. Both say invalid. I have logs from three different instances, but the errors from them were all similar. Two were throwing the warnings, and one was throwing errors.

To logon to your PW2 you use your Tesla Account email address + a 5 letter password that is ALL CAPS.

This password is not your Tesla Acc password.

It's the last 5 characters (ABCDEFGHIJ) of the password on the powerwall (all uppercase).

Using the email account on my Tesla Account (app?) and the LAST 5 from the sticker on the gateway this is the error I am currently getting.

EDIT: Here is how it is currently configured, hope this helps,and thank you for any assistance!

Using a browser, go to the IP address of your Powerwall gateway and try to login. When you can login there (as mentioned it should be the last 5 characters on the sticker), you'll have the right data to put into the app.

(your browser might complain that the connection to the Powerwall is not private, just accept it; on Chrome this means click "Proceed (unsafe)")

If someone other than Tesla installed your gateway, they might have changed it. If you can't get logged in using a browser, call your installer (or Tesla) for help accessing the gateway.

1 Like

Did you change the password on the wifi network by any chance? If you go to the IP address of the Powerwall (the one assigned by your router) in your browser, are you able to log in (as "Customer") using your email and the last 5 characters?

NOTE: what @jlv said above👆🏼

1 Like

I get to that screen, but no place for a password. I has me go outside and cycle the power toggle on the side of the power wall. Once I do that it logs in.

However I hadn't noticed the drop-down to switch from installer to customer. Once I did that, yes I was able to log in with the email address and the 5 characters .
Still getting the authentication error in the app:

Are you using the app from @snell or the Darwin app? I have the driver from @snell (the one this thread is for) on a backup C-5 and it works fine.

I haven't used the Darwin app, so that could be an issue with the app itself.

I have been using both. I couldn't find a thread for Darwin (though it appears it piggybacks in some ways (or at least uses contribution) @snell. The device driver in use (and used by Darwin is @snell (based on what I could make out in the driver code).

I came to this thread because I couldn't find one for Darwin, and trying to start a new thread I got no responses.

EDIT: PLEASE DISRGARD WHAT I SAID ABOUT PIGGYBACKING OR USING CONTRIBUTIONS.. As I look back I'm not sure what I was looking at, but it appears I was mal informed. I certainly don't want to cause any bad blood between people.

Looks like Im starting to get some different logs

OK - can you use just @snell 's solution and see if you can log in? I'm not sure about the Darwin app but looking at the app code, it appears to use the API token method for login

EDIT: It looks like the Darwin app does not log in to the local Gateway (it logs into Tesla servers), so I don't think your local gateway password will work

1 Like

Here is what I get when I added @snell driver

Interestingly, the UI for both is identical.

In Darwin's, there is an option, for tesla server or Local , I had both set up, so I would think at least the Tesla Server should work.

I'm not sure what the UI for the Darwin app looks like, but the screenshot of the device in the post looks like the driver from @snell (v 1.2.0).

However, mine has a bunch of additional data in "Current States" and "State Variables".

A couple of things to check:

  1. Can you ping the local Powerwall IP?
  2. On the device created using @snell's driver, click on "log on" and confirm if the logs give an error or not.
  3. Click on "Get Aggregates" and see if the data populates.

Not sure I can help a whole lot on the Darwin app as I don't use it. Though one other thing to try would be to remove the Darwin app completely to see if the @snell device works.

I'm having a brain fart. How do I do that?? I know in Darwins when you set up the app it does, and it said it pinged, but it was failing the authentication.

Try this app

Or you can use the HE endpoint

http://[YOURHUBIP]:8080/hub/networkTest/ping/[IP TO PING]

ahh never knew that (or at least forgot about it).

In the Powerwall’s IP/Hostname entry in @snell’s driver can you enter just the IP address (the one you pinged)? It looks like you have some other text after the IP address


That may have been it! I use Fing to monitor my network, and it does actually list a Hostname. So the way that looks, I had [IP ADDRESS]/ that hostname. (on both versions). I need to go to work, but I'll leave my logs open and see what happens.
The logs right after I made that change look promising though!

I do believe that error was from right BEFORE I made the change

1 Like