Need help trying to remove some Z-wave ghosts using UZB stick

I'm trying to remove some stubborn Ghost Nodes using the Hubitat UZB Z-Wave Stick How-To.pdf. I purchased a Silicon Labs UZB-7 and it installed properly in PC Controller. I got as far as Step 12 in the PDF and tried to pair the stick to my hub, but how? There is no pairing button on the stick so how do I pair it?

The steps to pair the stick are in the PDF...they are steps 11, 12, and 13.

In step 11 you are putting your UZB stick in pairing mode, via the PC Controller SW.

Depending on where you are sitting w/your laptop you may have to move closer to the hub to pair the UZB stick. In my case sometimes it pairs easily in my normal "work" location at home, and other times I have to temporarily move my laptop closer to the hub to get it to pair.


Before you move any further, please send me a private message. I would like to learn more about the inability of removing the "ghost" nodes.

1 Like

I'll share my experience(hub DID have the latest z-wave firmware update). Sometimes waiting a few days , the ghost can be removed via the HE interface. In another case(wink motion sensor) the ghost would not remove even after removing batteries, cold boot of hub, waiting days, hitting remove, and about every other technique I could find in the forums. Finally got it to be removed with the UZB7 stick

I had the same experience trying to remove two Fibaro ‘The Button’ buttons from HE.

Bought a Zooz Z-Stick and after countless cries for help in these forums, managed to remove them. I saw no need to keep the Z-Stick in the mesh other than as a repeater.

Took me a while, but in the end it's quite straight forward. The problem is the PDF has not been updated for the Gen 7 Sticks. There is no pairing button because Gen 7 does not support Classic Pairing, only Smart Start. To pair it to your hub click on Select > Smart Start in the PC Controller and it installs automatically as a S2 PC Controller.

From there it's pretty standard. Make sure the power to the ghost nodes is OFF before you start. Mark the ghost nodes as Failed, then click on Remove Failed and the ghost nodes should be gone.

Unpairing (Excluding/Removing) is a little tricky. PC Controller does not show up as a device on the Devices page, but it does show up on the Settings > Z-Wave Details page as a PC Controller. Make sure the stick is physically removed from your PC before you start. Click the Refresh button and after the page refreshes the Repair button should have turned to Remove. Click it and you're done.

Can you clarify what you mean by "...there is no pairing button..." please? Do you mean a physical pairing button on the UZB stick? There isn't any reference in the PDF to pressing a pairing button on the stick to join it to a hub.

Or do you mean that the Select Learn Mode button is disabled when you initially connect your stick to the PC Controller app?

A picture of your stick would be helpful...I have a UZB-7 stick (pic of mine below) from Silicon Labs and it works exactly as laid out in the PDF instructions. It's been recently updated to 18.1.2, but worked the same on all previous SilLabs Z-Wave FW versions. No one else has reported any issues w/the instructions in the PDF, using a wide range of UZB sticks.

Just realized - I hope we're referring to the same PDF. My references above were to the PDF found in this thread:

I've never had any luck removing a zwave device directly from the hub other than the brute force removal. I know hubitat does not reccomend the UZB stick method, but that's been the most reliable for me.

1 Like

I never had to use a stick to remove any Z-Wave nodes, but also, I am careful not to create ghosts, so that might have helped me to avoid using brutal force. The only time I had to remove ghosts, was on my dev hub when I was trying to create these impossible to remove ghosts.

1 Like

Since the recent Z-Wave FW updates I've found the hub to be much more capable of dealing with removing devices. Remove is definitely still not a 100% solution, but much improved over "the old days." :slight_smile:

1 Like

Thankfully, I haven't had to deal with ghosts since the FW update! But i tell you what, your guide saved my bacon a few times!

1 Like

Well I can appreciate and envy those who have not had ghosts, I have had many. I exclusively use GE switches and outlets going back to the Lowes IRIS days. Over the last few years, about 50 devices have failed (this is a known and documented issue with a particular line and range of their product.)

I have to say, Jasco/GE, have been great and I have had most of them replaced and hopefully past all that... Although I still have a few going throughout the house... I was told the defect didn't affect all of that particular line...

But when they fail, there is no removal process other than to force it and leave a ghost behind. They die with no way to operate the z-wave radio... I will agree the newer z-wave stack has improved things, but I have only been able to remove exactly one of those ghosts with the hub itself.

I've used a z-stick to remove the ghosts and update firmware for a while now and I've found the pdf instructions accurate. The only difference is on the hub side as the join without security GUI has changed.

I would remind anyone reading this and jumping into the use of the external stick to make sure you don't include it with security.

1 Like

[Shamefaced, he walks into the corner for his time-out.] :wink:

I know, I have to get that updated. I promise, before the end of 2022 (and probably just as HE rolls out a newer UI), I will update that!. :smiley:

1 Like

Seriously though, it is a very straightforward article and has helped me immensely! :slight_smile:


Thanks...and @erktrek gets a big portion of your thanks for schooling me/answering my questions. :slight_smile:

And wanted to note that I have some of those older Z-Wave GE switches that go south...another died recently and GE is sending a replacement w/out even asking me to show a receipt or anything. Their support has made me a Jasco fanboy for life.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.