Need help to understand the sequence of z-wave switch actions

In RM 5 I have to execute switch actions for a lot of z-wave switches. This doesn't work reliably. I assume a temporary overload of the z-wave net because all switch commands are performed at one time.

So I try to understand the sequence of z-wave switch actions behind the action lines in my app.

What happens if the action line is "Off: switch1, switch2, switch3, ..." ?
Do the command for switch2 start after the return of switch1 and so on? Or do all switch commands start at once?

Is there a difference, if I write separate action lines like "Off: switch1" and "Off: switch2" and so on?

What command sequence is performed for the switches, if I use a "Group and Scenes" app like "Select switches for group" = switch1, switch2, switch3, ... ?

Is there another possibility or recommendation to sequence the z-wave switch actions?

As far así know, the order is not defined if you do them all in a single action. It is probably arbitrary but should happen more or less all at the same time.

A better place to start is troubleshooting Z-Wave itself. Are you on a C-7 hub? If so, have you run the latest Z-Wave radio firmware update yet? Check for a "Firmware Update" button in Settings > Z-Wave Details, and click it if it's there--that means one ismavaip(it will disappear if not). Note that this is not the plain "Update" button on the top right--ignore that unless you're changing any of those settings. I'd also recommend updating to hub platform version 2.3.2 if you haven't already. Both of these contain notable improvements for Z-Wave, and even if you're not on a C-7, I think the latter is true for all hub models.

If that doesn't help (and possibly either way), I'd recommend looking into the health of you Z-Wave network. Lots of people here are willing to help interpret your stats if you post a copy of that Z-Wave Details table. There are also workarounds you can had like metering (spacing out commands) in Rule Machine, Groups, and some other apps, but the thinking is this should no longer be necessary with the above.


With newest hub and zwave firmware As stated, all commands are sent together. It seems to work pretty well most of the time for me. I think I just have some problem devices.
If you want to add a delay you can split the devices into two actions and do 1 second delay on the second one.

1 Like

Prior to the new hub and Z-Wave firmware, I created groups to handle this for me (using the Groups and Scenes Hubitat app).

I have common devices that I turn off (for example) when I set my alarm for the night or when I leave. I created groups for each "room", and put the Z-Wave devices for that room into the room (gave it a snazzy title like Z-Wave: Mater Bedroom). I then turned on "Enable Metering" and set the delay to 100 ms.

This worked pretty reliably for me prior to the new Hubitat firmware which says you don't need to do it anymore. Not sure what affect the new hub firmware has...but I'm leaving my groups as is.

1 Like

I'm on C-7, and I was on version 2.3.1. Now I updated the hub version.
I tried to update the z-wave firmware with the button in z-wave details, but nothing happened.

Now I will look and see, if things work better.

If the problems persist, I will try to analyze the health of the z-wave net. But I know, the network structure is not ideal. Some devices are connected over one or two steps.

So the idea with delayed (metering) groups might be helpful in this structure.

What button? The Z-Wave update has been available since 2.3.1, so it's possible you already did it. If you don't see a Firmware Update button (agian, not the Update button), you are already up to date. You can use http://hubitat.local/hub/zwaveVersion (replace hubitat.local with your hub's IP address if that doesn't work) to view your version. You should see something like this if it's up to date, key parts bolded (by me):

VersionReport(zWaveLibraryType:7, zWaveProtocolVersion:7,
zWaveProtocolSubVersion:17, firmware0Version:7, firmware0SubVersion:17,
hardwareVersion:1, firmwareTargets:1, targetVersions:[[target:1,
version:7, subVersion:15]])

1 Like

understood and checked: I'm on the newest version!

1 Like

I have analyzed the z-wave details. I have found and fixed a problem with one z-wave device. Furthermore, I have fixed a bad parameter in another device. But the reliability remained pretty bad.
So I have built some groups with metering. Now the switching works mostly with all devices, but very slow (caused by some long z-wave routes). This is ok for me.

Thank you for your help!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.