Need help on devices not responding

Hi there. I purchased the C7 and plan to migrate all my devices from ST. I have added 12 devices to the hub; mainly GE Z-wave plus switches. Everything work fine but then I notice some switches stop responding on the dashboard. Yesterday all the switches stop responding. Pressing the dashboard on/off button will give me the hour glass but the light won't turn on or off.
Going to the device page to press on/off doesn't work either. I try all the switches from the device page and they only work once or twice and then stop responding. I check the Z-Wave Details page and notice some of the devices show failed and some show Discover under the device tap. I try the repair button and it show no result. I have rebooted the hub, repair Z-wave and unplug the power a few times. It didn't help. I already submit an email to the support for help.
At the meantime, I hope someone can give me some advice on what else I can try. The last thing I did was adding Inovelli Z-Wave Smart switch to the hub. After connecting to the hub, it only work once (turning on and off from the device page) and it stop responding after that. I am not sure if it is connected to why all my devices are not working. Thanks.

My main advice would be: spare yourself all fiddling until the release of the next update, there seem to be many known issues like that with the current version and also in the Silabs firmware.

Some general recommendations I found to make my hub a little more stable:

  • avoid S0 security wherever it's possible
  • deactivate as many "motion triggers switch"-automations as you can
  • shutting down and unpowering the hub for one minute should bring it up on it's feet again. Have to do this about every 3 days
  • be aware that a network healing utilizes 100% controller load, so use with caution and deactivate all automations during this process. As for me, I only heal one device at a time and let the hub rest for 1 minute before doing the next.
  • have a close watch on how often and under which circumstances your devices report their values and reduce the threshold or the frequency.

Thanks for the advice. I have only 1 light switch that use motion sensor to trigger it. The rest of the switch I use Alexa to turn it on and off. I shutdown and unplug the hub this morning and it doesn't seem to help. I guess I just have to wait to see if the new update will solve the problem. I am just glad I didn't migrate all the devices from ST yet.

Open a new browser tab for the HE logs to be displayed and see if your hub is listing any errors.

The HE C7 Z-wave network in my case was terrible from the start. No update since has improved that.

I recently migrated to Homey; didn't want to go back to ST although I considered this for a while.
With HE I could not get a stable Z-wave network what ever I tried. Meaning: sometimes motion and button triggers worked as expected and other times triggers would start to fail for some period and not even showing in the device logs.
My issues are not because of bad z-wave circumstances:

  • My appartment is not that big: 90m2
  • I have 37 z-wave devices of which 8pcs. are wall power devices and 1pc. z-wave repeater (bought in the hope to solve my problems)
  • I never had problems with the same devices -even without the repeater- with SmartThings (only when the internet failed what was my reason to migrate to HE)
  • Since a few days I migrated all my sensors to Homey. I have the motion lighting setup for 2 days now and did not have any failure.

I am guessing this is goodbye to Hubitat.

I check the log on both the device and the hub. It shows "Z-Wave Network responded with Busy message.". I shut off the hub, unplug power and restart the hub. It works on some switches for a few minutes and then stop responding again. That busy message keep popping up on the log. Is that anyway to fix that?
I don't think Homey is selling in the U.S except on ebay. It sounds like an interesting device.

if your getting busy message you have ghost devices that were from failed zwave pairings that will need to be removed before it will work reliably


What's the best way to remove ghost devices? I try the z-wave exclusion but no device was found. I check my device list and everything is accounted for.

you can try turning off the switch.. if it has an air gap.. then shutdown hub, remove power for 30 seconds.. power up hub and immediately go into zwave details and hit refresh till you get a failed on the device then try remove. if not you can wait and see if nightly job removes them, or get a zwave stick to do it..

here is more

Thanks for the advice. After I try the shutdown hub method, I have 5 Not_Responding devices, 1 failed device and 3 ok devices with "Discover" under device and 1 device with S2 Access Control and blank under device. I try repair on the failed and Not_Responding devices but didn't do anything. The log show time out on repair. Does it mean I need the zwave stick or do I need to remove all the above devices and add to the hub again?

repair is never going to work.. they are not correctly paired devices.. you need to fail them and use remove not repair.

1 Like

After a few try, I finally able to get the Not_Responding devices to change to fail and giving me the option to Remove. If I do the remove, does it mean I need to pair them again to the hub? Also I think I find the 3 ghost device but there is no remove button to remove them in the Z-Wave Details page. It is the device with no name but there is no activity in the z-wave detail page. Not sure how to delete them.

show you zwave details page.. the failed pairings will have no in: and out: data on the page.

I guess the first 4 devices are ghost device that require the UZB to remove. What about the device that show failed? If I hit the remove button, does it mean I need to pair them again? Thanks.

The first node 01 is your hub. Don't delete that one!

Some thoughts:

  • A lot of us have had similar issues so you are not alone!!! Things are getting better with each firmware update so hang on!!!
  • The Z-Stick+ (or UZB stick) + Z-Wave PC Controller SW is a great way to take care of the ghosts and do some finicky pairings (like my Aeotec Recessed Door 6). I like the Z-Stick+ because I can use it to exclude things remotely (it has an internal battery).
  • Adding repeaters like the "Aeotec Range Extender 7" or "Ring Alarm Range Extender 2nd gen" really helps with reliability and inclusion. Yes I know that powered devices like switches should repeat just fine but in my experience for whatever reason this has been problematic.
  • Sometimes those devices can reappear after reboots/discovers/refreshes and also going back into inclusion mode. Not sure what the trick is but I've gotten things to show up from time to time.
  • Mentioning my recessed door sensor 6. When I tried to pair it with the C-7 it would force pair as S0.. I could not get it to pair unauthenticated. Once paired it would not respond. Using the Z-Stick as a secondary controller was able pair it again with no security and all was well.
  • If you seem to be locked out of inclusion do the power off/pull plug/wait 30 secs/restart and immediately try again.
  • As @kahn-hubitat mentioned the nightly process should (hopefully) take care of this.
  • Another issue that you hopefully haven't experienced is random S2 devices getting excluded and dropping off the hub after doing an exclude on a specific device.

Thanks erktrek for the suggestion and Sakman for the heads up. This afternoon all switches won't response. I check the log and get "Z-Wave Network responded with Busy message" every 10 second.
I did the shutdown and pull the power method and some of the switches come back while other still not working. I already order the Z-Stick and should be here on Friday. Hopefully getting rid of the ghost will solve my problem. The nightly process didn't help with my problem. I have all the switches appear in the devices area, they just won't response most of the time.
I just check the z-wave details page and most of the devices are "not responding, failed and unknown". Is hitting the remove button same as exclusion mode?

1 Like


Thanks for the reply. I guess this is the same as exclusion mode. The nightly process didn't take care the problem. Still waiting to try out the ghost removal method.

Not quite the same as Exclusion.
As I understand it, when Exclusion is used both the hub and the device forget they used to be paired.
When Remove is used, only the hub is instructed to forget the device.
Therefore the device will likely still think it is paired and should be Factory Reset before attempting to rejoin it to a hub.