[Nearing Release] Sonos Advanced Controller

Does anybody know what this log message means: "messaged has been enqueued". I'm trying to figure out what enqueued means in this context?

Does anyone in the community know the cause of this error?

dev:567 2024-06-26 08:09:11.937 AM error java.lang.NullPointerException: Cannot invoke method playerModifyGroupMembers() on null object on line 123 (method on)

I've been using Sonos without any issues for months, but this error showed up today. I can no longer use the Sonos Group controller. With the developer unavailable, I was wondering if anyone else has suggestions.

Edit

I figured it out! For some reason, the Sonos Advanced Controller was missing one of my Sonos devices, which happened to be the Group Coordinator. After running the discovery process, it found the device, and I selected "Done." Grouping now works perfectly.

1 Like

Is there any way to turn off the errors for Roam devices that are switched off? (I typically only use mine when I go out on the back deck or other places in the yard that I want to use it, and Otherwise I keep it turned off so that I don’t ruin the battery with it sitting there at 100% on the charger all the time.) The errors in the logs every hour are annoying, and there’s no Way to adjust logging for the child device. Thanks!

Does tts work on your sonos roam?

Yes

Hello,

I don't know what I could have going on here, but I have tried to get this app working and had zero luck.

I always get the error shown in the attached screenshot.

C7 Hub, latest FW, latest app installed by HPM.

Click "Sonos Virtual Player Devices"
Finds 6 devices, all primary.
Click "Next" button
Click "Click to set" and select all
Click "Create Players"
App shows "The following devices will be created: (all 6)
Click "Next" brings me back to main screen, and nothing looks different from first run screen.
Click "Done"
One non-functional player created in devices and returning to the app shows nothing different than the first run of the app with no virtual player devices shown.
If I run through it again, it will do the same thing again.

Network:
SonicWall router
Unifi access points (no VLAN or issolation)
Junpier QFX 10G copper

I tried a different access point, different "dumb" Negear 24 port switch, and I can't beleive the router is an issue, but I have a consumer router to try at some point. Network discovery works fine, so I don't think this is a Unifi issue. Playback on the Sonos app is fine. I grabbed a new off the shelf Hubitat just to make sure nothing installed on my main hub was interfering.

Any ideas? Cause I am stumped.

Update if this helps. The Hubitat integration does work.

Thanks!

I’ve got similar issues. The discovery part looks at my NAS and says it’s not a SONOS. I guess because it’s where music library is stored and address is held somewhere on SONOS. Also has looked at 192.168.1.1. Only managed to get two of my 8 Sonos devices loaded - an AMP and Roam. Had a Sonos One working at one point but reinstalled to see if that would help and lost it.

Apologies if this has been addressed somewhere in this long thread - I did attempt to scan through it but couldn't find any mention of my particular issue(s)...

I'm tyring to utilize this app to do some basic Sonos zone grouping/favorite playing. And, generally, it has worked pretty well. However, I'm getting intermittent failures for which I'm having difficulty pinning down the cause.

** Side note...I had these exact same problems when I utilized Sonos integration on the Vera platform, so I suspect the issue is with the Sonos API. But, wanted to ask just to be sure I'm not missing something obvious.

I have two simple rules setup...one to play a Sonos favorite (Spotify playlist) throughout my house (all four zones), and another to play "nap" music in my office (plus a couple others, but these two examples demonstrate the issue). You can see from the rule snippets below that the commands I'm using are very basic and they work about half the time However, in a scenario where I'm currently playing music throughout the house (all zones) and run the "nap" music rule, most of the time, ALL the commands will execute, seemingly somewhat delayed when watching the Sonos app, but the music will not actually play (the Sonos player will remain on Pause). The same happens in reverse - if I'm currently listening to nap music and run the "whole house music" rule, everything will setup correctly but Sonos will remain "paused." In my layman's view, it seems like Sonos is getting overwhelmed with commands and/or the "load favorite" command can't quite get to playing.

If I run any of these rules when Sonos is in full pause mode (i.e. nothing playing on any zone), they always work perfectly. It's only if I run the rule when Sonos is currently active doing something else that the new music/grouping doesn't actually play. Again, all the other commands in the rule are executing...zones grouping correctly, favorite loads, crossfade turns on, shuffle turns on, repeat-all mode turns on. But then it just doesn't play.

In an attempt to diagnose the issue, I added a delay to the "load favorite" command, figuring that might give Sonos the chance to catch up. That made no difference. One other thing I checked...if I click the "Load Favorite" button in the device control panel, even when Sonos is actively playing some other selection, it works perfectly every time - the favorite loads and begins playing. This intermittent failure only occurs with the HE rules.

Here are the two rules/command lists (note: Living Room is the group coordinator for the group 'Whole House')...

Whole House Music:

"Nap" music:
Screenshot 2024-07-07 at 12.58.05

What am I missing?

I’ve got similar issues. The discovery part looks at my NAS and says it’s not a SONOS. I guess because it’s where music library is stored and address is held somewhere on SONOS. Also has looked at 192.168.1.1. Only managed to get two of my 8 Sonos devices loaded - an AMP and Roam. Had a Sonos One working at one point but reinstalled to see if that would help and lost it.

UPDATE - now have 5 of my Sonos devices connected
AMP
Sonos One
Sonos 3
Roam
Connect (S2)

Three not Connecting are
AMP
Sonos 3
Playbar

So it doesn't seem to be the model that is casing the issue

Just wanna chime in to say that even though this isn't written with LAN mp3 playback in mind, it's working very well for me. I was pulling my hair out trying to get the old Sonos Integration driver to properly resume LAN playback after TTS.

So it doesn't seem to be the model that is casing the issue

UPDATE - After some more failed attempts at adding Sonos devices I tried watching the logs as I pressed the buttons on the screen. Gave me the idea to try pressing the “Create Players” button twice. Bingo! Worked for two of them . Last one I had to do this twice but all 8 are now added.

Next issue is trying to get the toggling of a group working - I'm trying to use a Zigbee button to group/ungroup two players with a single press but addresssing the group device as a switch and toggling isn't working - I guess I should be able to use some kind of state variable but I'm just a beginner so will need to eplore more. Also noticed that the group/ungroup commands take a few seconds to work.

OK. Thank you for that. I had to hit "create players" 6 times before all 6 units were added. Each time I hit the button, the next player was created, but I am still not having any luck with controlling from the Hubitat.

If I do anyting on the Sonos App, the change is reflected in the Hubitat, but I have no control over anything from the Hubitat. I have hit "initialize" and "save" on each device just to be sure.

I have attached a log from the one speaker and the controller. Something is really goofy here, cause I have now tried to get this up and running in three locations, and they all have the same issues. Two are S1 and one is S2. The worst thing about all of this is it did work in one location in the early days of this project. Something has to have changed.

(and as I said before, both the Hubitat native Sonos works, and the Sonos App(s) works)


This sounds a bit like I was experiencing - Sometimes it looked as if the Sonos device was installed but it wasn't properly complete - the way I could tell was that on looking at the details of the device under "Preferences" there was only one little box as opposed to the big list shown below on one that works - if you don't have this big list it wont work.

I ended up adding one device at a time rather than ticking all the boxes on the list of discovered Sonos devices.

Has this been released as of yet?
I get an error when I try to install it via HPM

Thanks for the assistance.

There hasn't been any releases for months, the developer hasn't been on here for a while.

It should still install though, the code repo is still there

THanks. Trying to install the app from the code produces an error (missing library).

Not sure what to do to make it work.

Strange, the file is there! Can you access the link I posted above?

I can, but when I install the app, I get a missing libraries error
EDIT: Just realized I need to install the libraries too. Will try that and see what happens.