Mystery (ghost?) Device - Can't Get Rid Of

I’ve done the repair, remove, reboot. No joy. It’s not in my regular devices list, so nothing there to remove.

Keep Logs (live logs) open when you try this and see what gets printed to them from the hub or "sys:1".

Below are the log entries - the first set (bottom) are when I click the "Repair" button in the Status column for that ghost node, and the second set of entries (top) result from clicking "Remove" for that node.

This would suggest the system can't find the node, so how do I remove a node the system can't find?

I wouldn't try a repair on a node you know doesn't exist--zero chance of that working, and you're just beating up the Z-Wave radio for no reason. :slight_smile: The "busy" message is concerning, but it could have still been working on the repair when you tried the remove (another reason not to try one before this).

Did you only do a reboot, or did you do a shutdown, pull power and wait, and then try again, as suggested above? Anything less won't restart the Z-Wave radio, which can help with odd issues, even though it shouldn't be necessary.

Did a full shutdown, unplug for five minutes, and powered back up. Ghost node still there. Again clicked "Remove". This time, log entry came back a bit different. But node still there.

That indicates that whatever the device is, is replying to the hub which prevents the forced removal from working. Most likely, it's whatever the next device in your Z-Wave list is. You'll have to remove power from the device for the force remove to work or use a USB stick with PC Controller to do a force remove with it powered up.

I had this issue and the key was removing power from batches of Z-wave devices since I couldn’t be sure which device spawned the ghost.

My ghost was a binary switch but the next 2 items below were battery powered motion sensors.

I turned off 5 circuit breakers and removed device batteries, shut down hub, unplugged it for several minutes, powered up and was finally able to remove the ghost with HE.

What's happening is that the device that created the ghost is still powered up making it impossible to remove. If you can identify the culprit (usually the same type of device right after the ghost) Power it down... Then shut down the hub and unplug for a few mins then power the hub back up and attempt removal of the ghost again. 9 times out o 10 you will be able to remove it this way. If it's the 1 out of 10 that just won't remove you will need a z-wave stick paired as a secondary controller to remove the ghost. The ghost will impact your mesh...

1 Like

Well, seems my ghost won't go away...

I've tried all the tips offered here (thank you). In my last attempt, I noticed that the device class of my ghost matched my Zooz Zen15 Power Switches, of which I have three in my network. However, none of them are "next in the list" to my is a couple entries higher in the device list, and the other two are several entries lower in the list. Nonetheless, I unplugged all three, shutdown the Hub, powered back up and again attempted to remove the ghost. No joy.

Sounds like my only option is getting a z-wave stick. However, I'm a Mac user, so that adds even more complication to this fiasco. I've only got 14 devices in this network - I'm seriously considering a Z-wave radio reset/network re-build, although I'm not enthusiastic about that. :expressionless:

What a bummer. I didn't have any issues like this with the network in my second home, which is 4x in number of devices & complexity.

You can install parallels and a demo copy of windows or use boot camp with a demo copy of windows.

The issue is NOT how many devices you have nor the complexity of your automation. Ghosts and their removal are a product of the Silicon labs SDK. They are created from failed pairings and from forced removals. It's not just applicable to Hubitat, it's applicable to just about any hub that uses the SiLabs SDK. (ST etc)

So, I've installed Parallels and Windows 11. Where I'm stuck, now, is which version of Silicon Labs I should use to get the Z-Wave PC Controller software. Should I install the Windows version of Silicon Labs and get the PC Controller that way, or should I just install the Mac version of Silicon Labs Studio, get the PC Controller through there (even though it only works in Windows) and then somehow run it in Windows through Parallels. This is where the instructions get confusing to me.

I started by installing Silicon Studios for Mac, and then installed the PC Controller software. Obviously, when I click to run it, I get a message it only works in Windows. So, if this was the correct way to get the utility, how do I run it from within Parallels/Windows? If this was the incorrect way...

I then decided perhaps I should've done everything from within Parallels/Windows, so I go to the link to download Silicon Labs Studios for Windows. That works, but when I click on the installation file, I get an error "Sorry, there was a problem mounting the file." I seem unable to actually install Silicon Labs Studios inside Parallels/Windows.

All of the detailed instructions in the How-to Guide are great, but on this particular point, it's vague. Any guidance would be appreciated.

PS: I ordered a Zooz UZB stick which should arrive tonight. So, I'm hoping to resolve this issue once and for all tomorrow.

The mac version does not work with pc controller, hence why we had you install parallels and windows. You want to install the windows version. Also make sure to log in to the actual software so you can install the pc controller software.

1 Like

Right, that's what I sorta figured.

However, while I can successfully download the .iso file for the Windows installation of Silicon Labs Studio, I can't seem to install it in Windows (Parallels). I double-click the ISO file and get the message "Problem mounting the file." I re-read the instructions on the Aeotec page, and it mentions to mount the .iso file as a virtual drive. I click the "Mount as Drive" when that file is selected, and again get the message "Problem mounting the file." :expressionless:

Install 7-zip and you should be able to just extract the ISO into a folder. I'm not sure if that would break the installation process, but I can't imagine it would.

Yep, thank you so much. I literally just figured that out myself two minutes ago. Installation underway now., Appreciate all the help.

1 Like

let us know how things go. Oh and when removing don't confuse hex for dec in device id

Did the UZB stick ghost removal this morning - worked like a charm. Boy, what a fiasco though. Certainly hope I don't need to do this too often in the future.

Thanks to all the respondents in this topic for all the guidance/support.

1 Like

If you ever have a failed pairing just stop. Check for the ghost and it should remove easily. Re try pairing again..

Well, I've got another ghost device - this time, I know exactly where it came from. I had yet another Zooz power strip (1st generation) fail - just completely fried and no way to cleanly exclude it from the network. Can't get rid of its ghost through any of the basic ways. What a PITA. I know what I need to do with the Zwave stick, Silicon Labs, etc., so this is me just lamenting - but I wish I didn't have to jump through all those ridiculous hoops when something like this happens and there was a way in HE to get rid of these.



We've been there, felt that.

But from the glass half-full perspective, at least we have the UZB path and incredibly helpful community members. :slight_smile:

Hope your removal goes smoothly.

@rlithgow1 - not a mac guy. Do I need to update anything in the instructions for the mac part?