My hub crashes/shutdown if not every night then every other night

My C8 hub keeps shutting down for no reason. Every morning, I wake up and it's off and unresponsive, with a red LED. I don't have ton of rules on it, I only have 8 basic ad simple RM rules.

Would some automation rules make to to go go down?

Hub info: Version:
Hardware version: C-8

Any help would be appreciated.
Thank you.

First go into the hub and perform a reboot with the advanced option to "rebuild database on reboot". That is basically a soft reset and restore and should eliminate corrupt data in the DB.

Can you get into the Diag page when the hub is in this state? That is going to your url's ip address with :8081 at the end of it.

Are you using the power supply that came with it. If not please switch to the included power supply to troubleshoot if that could be responsible. I have heard that the C8 is very power sensative and so using a power supply that fluctuates out of spec could cause problems.

All the above advice is solid, adding to that:

Off with a red light by itself is very curious, normally the only way to get that state is by clicking the shut down button in the UI. If it lost power it would reboot itself. Usually if it crashes it will either still have a green LED or sometimes it will reboot and get stuck on the blue (booting) LED.

Check Logs > Hub Events, see if there any any shut down logs


1 Like

Yes, I'm using an original power supply, that's plugged in to online, pure sine UPS. Hub was reset to a factory defaults recently and I did try to reboot it with the database rebuild option. I didn't do this prior to the factory reset and that's why I tried to look at the rules, thinking that there might be something going on there and I can't figure it out.

Is it possible that one of the RM rules just crashing the whole hub?

When it crashes, I can't even ping it, it's like completely dead.

@jtp10181 Here is the screenshot of my Hub Events. Some logs are not shown here as I think I did "Purge Past logs on reboot" option at one point

That's what I thought about the status LED. The only way to bring it back , would be to unplug, and plug it back in.

So I would guess these marked entries are when it shut down on its own? Since there is a start but no reboot or shut down log:

Have you checked the past logs for errors? Or possibly even the last bit of things logged before it goes offline would be useful, possibly also telling the time it went offline.

Highlighted time stamps are when I had to reset it, and not necessarily when it shut down. There were times when I was like, screw it I'll deal with this later.

There is noting in the logs, only Info, couple of debug that I need to disable, and couple of warnings (Received local request for App 601 that does not exist, path: /devices/1092/active from unknown) that I'm chasing right now.

Is it connected to your network using a wired connection or Wifi?

If it is wireless have you tried having it wired to the network?

If it is Wired have you tried a different ethernet cable?

By chance do you have Jumbo Frames turned on with your local network, or use POE for anything?

I noticed the red light occasionallly when doing rest on my device after it rebooted. I was starting think it might be related to activity on the Radio part of the hub.

It's connected with CAT6 to my Cisco switch (SG500X-48) which is not PoE and MTU is set 1512. I tested the cable, and it's passed the test.

There is no issues communicating with it as long as the LED is green.

I did have an issue earlier, where it didn't register the fact it was connected via wire, and it was broadcasting SSID as an open AP. Here is the threat for that issue.
I was able to resolve it by removing static IP rebooting and setting it on a static IP again.