My first crash, what do I do?

So last night I performed a software reboot and went to bed. I didn't watch it to see if it would come back up because I just thought it would. Then this morning none of the automations would work. The web page was not responsive at all, but I could ping the hub. I then logged in via :8081 and performed a reboot there. Now I'm getting the hub is starting up page but it's stuck at about 90% done. What do I do now? I can still get to :8081. I don't want to do anything else without some guidance here.

Can you still get to 8081? If so maybe download a backup, do a shutdown then pull the plug on the outlet side, wait a few then power up again and see if that helps. If not then maybe try a soft reset with the backup you downloaded.


I'd do exactly what @erktrek recommended. I think it is likely there is database corruption - if it doesn't self-correct during boot, then a soft reset is an excellent idea.


Ok I shut down via :8081, light turned red, and I power cycled it. I'm back in, but it appears to be a defaulted box now. It didn't ask for a password when I logged in, no devices are installed, the only app installed is basic rules. What happened? :frowning:

My logs are still intact. Is there something there somewhere that will help?

The database was corrupted.

Ok - first, don't panic (I've been there). Go back to :8081, and do a Soft Reset - especially read the part about how to restore the old database in the link that @erktrek posted.


Do what @aaiyar recommends. You don't want to reset the radios. Restoring your database should get you back after the soft reset

Performed the soft reset, then on startup screen tried to restore from backup. Using the backups that were auto saved wasn't working. The hub didn't even appear to reboot when choosing those. I then chose a manual downloaded backup that I did several days ago and got the prompt that it was rebooting, but when it came backup it's still a defaulted box. Shouse I try a full reset?

I would engage support at this point. If you do a full reset you will have to re-pair every device, even if you get a backup working. Not fun.

And how long did you wait on the restore of the backups? It takes a while sometimes.


It took a few minutes before a refresh let me back into the system.

Will support help me here? Or do I need to go issue a trouble ticket

Trouble tickets are a good idea.

Tagging @bobbyD (from support) can help. And @gopher.ny is the hubitat DB guru, so he may have some ideas as well when he comes online.


I think I know what's happening... here's the workaround.
On the green startup screen, click on Get Started, click Next on all intro screens, and enter hub name/location (anything will do, it will get overridden shortly). Once in the normal hub UI, go to Settings - Backup and Restore, and restore from there.


I just tried this and after reboot it comes back to the get started screen. I'm considering a hard reset and starting over since I'm not super far into this journey. I only have 20 devices so far, but it's been a learning process and I'm sure I've made some mistakes along the way. Before I do that though I still have access to the logs. Is there any way to find out why this happened so I don't repeat it?

It seems like the backup you have and are restoring is of a blank hub. Try using an earlier backup.

The Hard Reset is not going to help as much as you think, I suspect. You can do the same "start over" in a couple minutes by going into each Z-Details page (ZWave Details, Zigbee Details) and click the Reset you find there.

All the work is in reseting the ZWave devices. The hub is pretty quick and easy in comparison. :slight_smile:


What happens if you download backup file first and try restoring it from the downloaded file instead of directly?

Don't do a full reset - it's just going to unpair the devices.

1 Like

Ok you were right. I restored the one from a day ago and now its back up with all my devices and rules. I'm not home to see if everything is actually working, but I assume it is. I'm still nervous about why this happened. Anyway to know for sure?

1 Like

@waffles - I think @csteele makes a great point. Can you download the backup file? What is the file size?

I'm checking it out. Whatever the findings, the fix will make it into 2.2.7.