My experience with HE

Aye,
So i installed maker API, made a virtual device (presence sensor) went to maker API and exposed the PS to it. Clicked GET ALL DEVICES and got the unique ID.
Copy and pasted ur 2 URLs - arrived and departed - placed in my DEVICE ID
Pushed them both to my phone and pasted them into my home location trigger arrival and trigger departure and saved it.
Is that all I have to do ?

An iPhone turning off WiFi when asleep is not normal behavior. Mine does not do it. But there are reports other than yours of it happening (seen via a web search). Whatever the issue is is not Hubitat related. The issue is somewhere in your networking or phone.

Network steps:

  1. Make sure router firmware is up to date
  2. Set static DHCP reservation for phones

iPhone settings:

  1. Make sure Location Services is On and the Hubitat app is set to "Always"
  2. Make sure Background App Refresh is On and active for Hubitat app

iPhone network troubleshooting. These steps can fix weird networking behavior

  1. In WiFi settings forget the network. This is a simple procedure, you will have to just re-enter the WiFi password.
  2. If that does not work then you should "Reset Network Settings" from General>Reset menu. This resets all Wi-Fi networks and passwords, cellular settings, and VPN and APN settings that you’ve used before. The only downside to this procedure is that you have to re-enter all WiFi and VPN passwords.

Correct. However it does seem to disable certain wifi functions when goes into sleep mode after a few minutes.

For example, it will stop responding to ping commands, but will respond every now and then as it checks for various things. I measured a few iphones over the course of a few months and discovered that they would stop responding at times for up to 15 minutes max. This occurred mainly at night when sleeping. A lot of the network presence sensors were based on using ping so you have to set the timeout to 15 minutes before determining it truly is off the network vs just asleep to be safe.

We did discovery in another thread though that it responded to http commands differently with different errors if the phone was in sleep, deep sleep, or off the network. So that method has been pretty good for determining wifi presence.

And my favorite method is using arpping to determine network presence as the phone seems to always respond to this (and stop responding for a max of 6s) no matter what mode of sleep its in. This method gives me a very accurate state of the device.

I'm not sure what routers use for device presence, but I also have a FingBox and know it would take 20 minutes before it determined the phone was off the network. I figure it was using the ping method.

Of course I can only speak on the iphone as I don't have any android devices to work with, but you never want to rely on one method. I combine it with something like L360 and get very good results.

Hmmm...:thinking: Every iPhone I have ever tested does stop responding via its WiFi connection for specific periods of time when the phone is asleep (screen is black.) I have never had one maintain a constant WiFi connection when asleep, unless that is something Apple recently changed in iOS13 or newer iPhone hardware.

iPhones will maintain a connection to the wireless phone carrier network while asleep, which is how they will respond to phone calls, SMS texts, Push Notifications, and iMessages while sleeping.

4 Likes

I can verify this - I can see this pattern when I look at device uptime using my Fingbox. At least with an iPhone 8 and an iPhone 6P.

1 Like

I haven't used Locative in a while, but my directions that I wrote up are available below. Just a heads-up - recently Locative started getting some updates, at least for iOS via the Apple App Store. I have not personally tested the newer versions of Locative as Life360 has been working pretty well for us lately.

I don't think this is correct. My iPhone with cell radio off and WiFi on still gets and announces messages when screen is locked. Also non-cellular iPads or iPods get messages/calls when locked, plugged in or not. Low Power Mode also does not seem to have an affect.

As I said, there are certainly web complaints of WiFi dropping when locked. There is no official Apple documentation of expected WiFi performance when locked that I've found. I don't believe that WiFi 'off' is expected behavior. Otherwise there would be even more complaining and likely documentation.

I'd certainly try resetting the network settings. It does seem to be a magic tool for many network issues.

What you say is true because the Messages app and iMessage can send/receive over WiFi on iPhones and iPads. If a device's cellular option is turned off, calls and SMS texts over the cellular network will not work. Newer devices have the option to use WiFi calling, but how well that works depends upon the strength/signal quality of the wireless (not cellular) network. Lastly, if cellular is enabled and the device is sleeping, a connection to the cellular network is still maintained.

Yes, that is correct. I was responding to a statement that WiFi on iPhones turns off when in "sleep". They don't for me. Nor is there any official documentation that it does. Some people have issues of WiFi dropping. But I don't believe it's by design. If the issue is on the phone then resetting network settings is probably the most likely to clear things up. I saw some anecdotal reports that phones have exhibited different sleep behavior on different WiFi access points. That's a little harder and time consuming to try out.

If your phone is connected to a power source while locked or in "sleep" mode, your WiFi connection is maintained. It will disconnect if not connected to power. This has been discussed on Apple's own discussion boards and most agree this is by design. However, many people do not realize this occurs because the cellular option is usually always left on and does not disconnect while the phone is locked/sleeping.

1 Like

Not for me or any of my family's devices. All maintain WiFi connections while locked whether plugged in or not. True on devices with (disabled) and without cell radios.

Apple has not put forward any official documentation on expected behavior that I've been able to find. There's not even any mention of disabled WiFi in Low Power Mode documents. There are a few highly opinionated people on the Apple discussion boards who claim that WiFi gets turned off by design.

It doesn't make any sense for WiFi to be disconnected when locked and not plugged in. There are too many use cases that would totally get hosed if that were true. Some apps may require being plugged in to use WiFi (like iCloud backups), but that's at the app, not OS level.

I Know my Android phone disconnect wifi (to be honest it keep it in a sort of cold standby for eventual fast resume) and I know that is a default habit for Androids.
I believe that is usual for many phones.
It was discussed in a topic (I cannot recall it in this instant), about an HE app able to poll Apple cellulars to simulate a presence device.

EDIT: HTTP Presence sensor

2 Likes

Yes, you are correct, these devices still get notifications while asleep. However, these devices, while asleep, will save power for quite a bit of time by dropping/minimizing the WiFi connection. This is, as @roberto mentioned, a designed power saving feature. The iPhones and iPads will still wake up the WiFi connection periodically, check to see if there is anything to do or receive, and then go back into this power savings mode.

The iPhone HTTP Presence Sensor driver polls the device via a HTTP call to see if it is on the WiFi network about every 1 minute. While aspleep, iOS devices will stop responding for a decent chunk of time, and then resume responding for a while, then stop responding, etc... This is the phone trying to save battery life by minimizing its use of its WiFi radio. It also explains why the HTTP Presensce Sensor method is only part of a solution for presence detection.

If there is a magic set of iOS settings that would keep the phone's WiFi active the whole time (without trashing battery life), many of us would be very interested in know what those settings are.

UPDATE: Once home, I ran a quick PING test against my iPhone 11 and my iPad Pro (WiFi only) and both devices failed to respond to ping requests about 80% of the time when their screens were off (i.e. asleep.). Both devices start responding to ping requests for a short period of time, and then they stop for a while, start for a while, stop for a while. It is very consistent and appears to be deliberate.

Whilst I appreciate the discussion,
My router is up-to-date
All my useful devices have static IPs
location services is on
Background app & mobile data are active
My wifi aint the issue.

Now if y'all had this much information on how to get my geofence to be working we'd be laugh'n ~!

3 Likes

The past 2 days have been bliss on Locative (not to jinx myself)
Both phones, coming and going, not bouncing out of the fence and me not having to hide the step ladder from the mrs because of the siren~!

4 Likes

Here's an interesting one,
It seems either pushover @mike.maxwell had an error and crashed my hub

or possibly the harmony driver crashed it ? @ogiewon

Any thoughts on what might be the issue ?
I noticed some foul play this morning but didnt want to restart the hub on a hunch so left it, but then noticed the mrs hadnt left the house/no pushover message so checked and found it sitting there working, with events that hadnt been logged.

Restarted it and it came up that the zigbee stick had stopped working,

Restarted it again and it seems to be back up.

Any ideas either @bobbyD ?

Hmm, clicked my remotec zwave switch, then had to wait 20 something odd seconds for the light group to switch on.

dev:3562020-02-12 07:45:43.113 pm [info] four livingroom lights switch was turned on

dev:6802020-02-12 07:45:43.097 pm [info] Hue AL 1 was turned on

dev:6842020-02-12 07:45:42.909 pm [info] Hue AL 3 was turned on

dev:6852020-02-12 07:45:42.857 pm [info] Hue AL 4 was turned on

dev:6842020-02-12 07:45:39.778 pm [info] Hue AL 2 was turned on

dev:912020-02-12 07:45:27.036 pm [info] Remotec Switch button 2 was doubleTapped

Not sure where to go or what to do with this (system).
Im just getting tired of the inconsistency.
So, Locative has been bang on for months, but then all of a sudden its slow, it took 25mins to reg I had left the house.
Did a shut down restart the other day and then all my zwave - mains powered devices take forever to reg movement.
Pushover just stopped working one day. Came home, clicked save and it started working again.

I just want to build it to a point and then let it run, but I cant. Things get slow, things stop working. Tried with bobby but after awhile he stops answering or doesnt explain things fully then doesnt come back to me with an answer.

Ive had great times with the system, but if I dont change anything, I kinda expect nothing to change. But that doesnt seem to be the case. Pls note I have a very small system / house. I built my mesh up and dont mess with it. im on the right channels and have had a time where 6 weeks went by and not one issue, but lately it seems im pulled back to the system time and time again to work out why something has stopped or something else isnt working.
Its frustrating.

Sorry to hear about yoru continued problems.

I had the same for months. I got a second HE hub. I moved all risky devices/apps to the old hub. My older HE hub ran faster than my newer hub with all my rules. It didnt fix the problem. I bought a Xbee to trace/map my Zigbee network. It wasnt the problem.

I finally decided to move my automations to NodeRed, and use Hubitat for device control only. I'm not fully there, but 90% of my automations are now with NodeRed.

I experience faster rule running, very few DB errors, and better satisfaction. My experience has led me to believe that HE struggles with many rules. My backup size has reduced from 35MB to 19 MB.

My recomendation: look into Node Red. I also have a pretty cool dashboard too.

4 Likes

This @stevebott123 is what I am finding as well.

The second hub with these problematic Z-Wave devices I have, now leave my main hub to hum along. It is still necessary to reboot only the hub that has the problem children on it every day on a schedule, but I don't care that it does that. It's working well, and I saved the $300 it would cost to replace them.

I do not use NodeRed, but just splitting the devices I know are old and chatty has made all the difference.

1 Like

Download the Hubitat app