My C7 -> C8 Upgrade Nightmare

I made the mistake of taking a well-working setup on my C7 and upgrading to a C8 in hopes of getting more reliability with my Z-Wave devices. I followed the instructions in the official migration doc and it has been a terrible experience. None of my Z-Wave devices (Aeotec Multi6, Ecolink Tilt Sensor, Ring Contact Sensors, etc) worked after the migration. All four of my Nests no longer communicate with Hubitat, my Hubigraphs are all broken. WebCore no longer works which really sucks because I have a massive rule to control one of the AC units upstairs so my kids' rooms are cooled properly versus being either ice boxes or saunas.

I reset the ZWave radio and can't get half the devices to pair. It took me three hours trying to get the Aeotec Multisensor to pair. I deleted a reinstalled Google SDM but my Nest still doesn't properly respond so my AC units run constantly. I'm going to have an insane electric bill this month as a result of this migration.

I know many people have had success but there are a large number of people who have not had success. I recommend people think long and hard before migrating.

1 Like

Could you confirm you were aware and followed the following?

1 Like

Did you do a power cycle? (shut down and unplug for 1 minute then power back up?)

It is noted in the conversion video you may have to reauthorize certain cloud devices.

You need to get the 2 things above settled.

You can also reset the c8 then re migrate and see where the issue was.

On c8 reset both zigbee and z-wave radios. Then do a soft reset.

On c7 please make sure you're on the latest platform. Make sure you do not have any ghosts as they will transfer as well and wreak havoc on your mesh.

Once you are sure of those things then do the migration back up, shut down the c7, then bring up the c8 and restore to the c8. Any wifi based integrations you have WILL need reauthorized.

I'd add to above:
...disable the C7 Zigbee and Z-Wave radios, then shut down the C7 and then unplug the C7...


I got my Z-Wave devices working again by spending the better part of a day trying over and over again to Exclude and Include each device and replacing the respective device in ever rule, graph, and dashboard.

I got the Nest working again after about 9 attempts.

Hubigraphs worked again after a couple of reboots.

I had to blow away my Webcore rule because nothing was or still nothing is working with Webcore.

Yes. This is what I followed.

1 Like