My brand new C-8 bricks my LAN internet access

Hi - I just received my new C-8 today.

I started to go through the initial setup at, but it would always fail to connect to the C-8.

I started trying to research this connectivity issue, when I was surprised to find that I could no longer get to the internet whenever the C-8 was attached to my network switch. My LAN network 1G/100M switch has a number of connected devices (of course), and this switch is connected to my router. The router connects to the internet.

Unplugging the C-8 from the switch allows my PC to reconnect to the internet. Plugging the C-8 back in prevents my PC from accessing the internet. I can communicate on my LAN with the C-8 plugged in, though.

What is going on here? Is my new C-8 D.O.A.?

Have you tried changing the Ethernet patch cable between the hub and the router?

Does the Ethernet switch stop working when the HE hub is just connected to the switch, but not powered on?

1 Like

Maybe tell us something about your network like what brand switch and router you have, and how things are connected (wifi repeaters, wired switch, mesh network, etc)

Is it possible the Hubitat is on the same IP as another device? How do you manage address reservations in your router?

1 Like

do you have both wifi and ethernet active, maybe creating a loop

when ethernet cable is disconnected, try to see if hubitat is still online

@kkossev - Yes, I've tried two different RJ-45 cables, one that shipped with the C-8, and another that I have used successfully with other devices.

I haven't tried seeing if the switch stops working with the HE hub unpowered, I will try that tomorrow and reply back.

@neonturbo - The router is a Netgear Orbi that has worked flawlessly for years. The switch is an 8-port D-Link 1G/100M autoconfiguring switch, which has also worked flawlessly for years. The Orbi is the only DHCP server for my LAN (as it should be). For a small set of devices, I have set up reserved IP addresses within the Orbi configuration. I can see in the Orbi's IP address table that the C-8 has a proper address assigned, and there are no other devices on my LAN with that IP address.

@jschlote - By WiFi and Ethernet active, do you mean on my LAN? If so, the answer is "Yes". If you are asking instead about the C-8, the answer is "No". When I have the C-8 connected to the switch, it is assigned an IP address by my router. However, I have not been able to connect to the C-8 yet through its configuration page, it always seems to fail (possibly because the internet is dead when the C-8 is connected?). As a result, the C-8 hasn't been configured for WiFi, and it isn't visible on my LAN when the Ethernet cable is disconnected.

Just to be clear, your hub is getting a reserved address from DHCP, as opposed to setting aside an address on the router and then manually setting the hub with that address? If the latter, the DNS addresses are not set, even though it appears that they are. You have to manually set them. Although this still wouldn't explain why your wired(?) PC cannot connect to the internet.

@ADiamond a couple of things come to mind...

Some orbi defaults to /23 instead of /24. Check that. It can cause issues

Is your orbi doing router functions so it's switch>>orbi>>isp's equipment ? If so is the ISP's equipment set to bridge or passthrough mode?

For giggles press the network reset button on the bottom of the hub for 7 seconds with a paperclip or toothpick. It will be the only round hole out of all the square ones. This resets the network only. Nothing else.

Do you have jumbo frames running anywhere on the network?

Are you using the factory power supply or a poe adapter?

1 Like

...and another thought. How many LAN devices do you have currently (Orbi limit is near 250)? Also could check to see if your hub is getting the same IP as another device (maybe your PC).

1 Like

when you go to, are you using vs

1 Like

Things are a little different this morning, though I am still unable to connect and configure my C-8. I can connect to the internet with the C-8 connected to my switch. However, the Hubitat hub search is either unable to see the C-8, or it comes up with the wrong IP address for the C-8 during the search.

Using the configuration webpage, the hub has never been discovered on the basic discovery page, I have always needed to use the advanced discovery page.

A little more information about my home network: My Orbi router is configured to use a less common - but totally legit - reserved private LAN range: thru I can't use the typical 192.168.x.x home network addresses due to weird conflicts with my ISP modem.

I have a Verizon 5G Home Internet gateway for my ISP. The 5G gateway is configured to have all of its router-related functionality disabled (DHCP is disabled, all WiFi radios are disabled, etc.) The connection between the Orbi and the 5G gateway is a stateless autoconfigured IPv6 P2P connection on both ends, with IPv4 disabled on my Orbi, The gateway-Orbi P2P connection is set up as a passthru DMZ connection.

My goal was to make the 5G gateway as invisible to my Orbi and LAN as possible, and letting my Orbi be as unobstructed from the internet as possible (acting similar to an old cable modem). About the only functionality I have enabled on the VZW 5G gateway is its DDNS service, since my gateway switches IP addresses very frequently, sometimes multiple times in a day.

@jameslslate - The hub is getting all its network configuration from my Orbi router, the hub is not being configured manually at all.

@rlithgow1 - I have provided more information about my LAN configuration above, maybe it will help.

@thebearmay - I have about 25 devices on my LAN. Most are configured for the main LAN, some are auto-configured for the guest LAN (which the Orbi DHCP assigns in the range). The C-8 Hub is connected to the main LAN, and has been assigned an address of by my Orbi.

@jschlote - I have tried http and https, no luck with either.

Since you are using a Class B network, you need to configure the Hubitat to use a Class B network mask.

Please read the thread linked to below for the issue you've run into, as well as one solution.


Busch Beer GIF by Busch

Well ... as if things weren't acting oddly enough ...

I seem to have my C-8 operational at this point, and hopefully reliably (TBD). I haven't done anything with regards to the Class B network subnet mask - yet.

When I started this thread last night, I couldn't connect to the C-8 through the webpage. I also couldn't connect to the C-8 directly by using its Orbi's assigned IP address.

As I was struggling with this issue this morning, and after my 3rd Orbi reboot, I was finally able to connect to the C-8 by going to its Orbi-assigned IP address ( still didn't connect). I went through the slightly different Hubitat setup screens, and I was able to download and install the latest C-8 firmware update.

I set up the C-8 to use WiFi, and I have set up a static IP address for the C-8 WiFi connection in the Orbi. I have bookmarked the http://172.16.1.yyy address for future easy access.

I have also enrolled my Z-Wave front door lock and started setting up Lock Code Manager.

Will I still need to make modifications to my C-8's configuration for the Class B network? While scanning the recommended thread, it seems like it could be a bit painful.

Maybe a silly question, but with so few devices in a home environment, why use the larger class B subnetting scheme?


@marktheknife - Nope, not a silly question, but I needed to use something other than the typical 192.168.x.x IP range to prevent IP address collisions with my cable modem in the past. When the Orbi router was configured in the 192.168.x.x IP range, there were times that I was forced to factory reset the Orbi router in order to regain access to the configuration pages again, even though the Orbi was fully functional otherwise. Neither Netgear nor the cable modem manufacturer could explain why it was happening, but Netgear recommended using a different IP range to resolve the issue, which it did.

I didn't want to use the larger 10.x.x.x range, although it was available.

Were you doing double NAT, because normally you get an routable (public) address from your ISP and then use a private address for your local network. If that is the case, you can still use 172.16.1.x with a subnet mask of (Hubitat's default) and a default route of your router (probably


This is what I would do. Just because there's an entire RFC1918 private Class B available, doesn't mean you can't just use one class C slice of it. You have a lot going on here. IPV6, 5G, double NAT. Once you have everything working I would suggest you document it like crazy. And because it is so complex I would make sure things are nailed down. The Class B/C thing is an example. If there's a mask mismatch someplace it might accidentally work for awhile, but then a random reboot somewhere breaks it. Understand every configuration choice. Verify it. Document it. Because later when you're either troubleshooting this or asking for help, a good diagram/document will be invaluable.


If you still can't get to your hub via this URL, you likely have a DNS issue and may need to manually configure DNS on your hub.

1 Like

So larger ranges aren't determined by scopes. 192, 172, 10. Are pretty much reserved scopes for private use. What's determines scope is your subnet. So you can set your subnet to /24 ( regardless of what the scope is 192.168.1.x is. Otherwise with a /16 you're flat networking 65000 ip's which can be ok but can cause problems with some iot devices. I would shrink your subnet down to /24 and if you need more than 256 network devices then simply vlan off using the next one up while still maintaining a /24 for that subnet


It was probably double NAT'd, but they were also using the same ip address range of the OP's Orbi Router. That is pretty crappy of them to use the 192.168.1.x network space and screw anyone that uses a personal router. Almost all consumer home routers default to the 192.168.1.x network space when initially setup. Just starting their NATing at the network would of prevented for the OP is problems most likely.

Unfortunately this isn't as uncommon as you would hope. I had a friend that couldn't get his personal router working. Upon investigating it I found that his ISP was NATing his external ip and did the same thing. This was probably 20 years ago at that point. My ISP while I have had them changed from Public IP's for customers to a GNAT'd ip unless you pay a extra $5. It is a cash grab because of the thought they are running out of public IP's. If they would just switch everything to IPV6 this wouldn't be a issue, but it is a way to justify charging you for functionality of being to actually get back to your home from being remote.

As a few others have mentioned though just because the private range of the 172.16.x network space is a class B network doesn't mean you need to set your router to use the whole thing. It just means you could if you wanted to. If you just specify the third octet and then set your subnet mask to then you will be back to a class c network and a limit of 253 hosts, or a typical consumer network.