My 2gig CT100 Z-Wave Programmable Thermostat does not seem to be working with Hubitat

Today I received my new hub and have so far hooked up all light switches except for two that are not responding, and my two door locks which I have not gotten too. I have a 2gig CT100 Z-Wave Programmable Thermostat that worked perfectly with my Live Watch Security IQ panel. It comes up on Hubitat as a Generic Z wave controller, It is a battery operated Thermostat. From the device screen no matter what I do it does not seem to be updating the Thermostat. Plus frankly on the device screen the controls are crazy compared to the IQ panel where you simply selected mode, and Temp. The auto mode never worked right on the IQ panel. What do I need to do to get this working. Auto control of the Thermastat was a major reason for coming to Hubitat after my IQ panel died. Help.

Can you share a screenshot of the device settings page? It sounds like you may need to manually change the driver that was auto-assigned to the device when it paired.


This item is solved. I was trying to set the thermostat from the device screen and it did not seem to be working. When I created a Dashboard and added a tile to it, now it works. I am very happy so far. Have added the thermostat, all lights and dimmers. Today I will tackle my front and back lock.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.